Announcement

Collapse
No announcement yet.

"Folder empty" tip issue...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Folder empty" tip issue...

    Manytimes, when compare two folders with quite many files (>300), BC displays the "Where did this folder go" tip.
    It says that an empty folder was removed from the display.
    The problem is that there is no empty sybfolder in neither of two compared directories.
    Is it a bug or did i miss something ?

    (BC version 2.2.3 b221 registered - WinXP Pro/sp1)

    Thanks
    Sakis

  • #2
    Re: \"Folder empty\" tip issue...

    Do you have View|Always Show Folders turned on? BC won't show empty folders unless you turn that feature on.

    If you don't have View|Always Show Folders on, you can also use View|Supress Filters to make empty folders show up.
    Chris K Scooter Software

    Comment


    • #3
      Re: \"Folder empty\" tip issue...

      I do have Always Show Folders turned on but that's not the problem.
      BC displays that tip although there are no empty folders. Don't know why, but it detects something as an empty folder even when i only have two similar directories filled with ordinary files and no subfolders at'all.

      Thanks

      Comment


      • #4
        Re: \"Folder empty\" tip issue...

        Do you see the same thing when you are comparing other folders on your system?
        Are there any hidden or system files in the folders?
        Are you filtering out any files?
        Chris K Scooter Software

        Comment


        • #5
          Re: \"Folder empty\" tip issue...

          Let me explain the exact situation

          I have a subdirectory named \SYM filled with 800 binary files with extension .RCL (my project's data files)
          Created a second folder on the same disk with name \NEW and copied those files over there after some conversion (same extension though).
          Tip is always displayed when i started BC comparing \SYM and \NEW to check if all files been converted.

          Are there any hidden or system files in the folders?
          Of course not, double checked.

          Are you filtering out any files?
          No

          Do you see the same thing when you are comparing other folders on your system?
          Didn't notice that before, but i'm using BC just a few days now.

          Btw i've installed same BC version on a different computer with clean installed system (WinXP/Pro, sp1) and it has the same behavour.

          UPDATE: Something i've noticed later after deleted some files, tip stopped displayed when only left 300-400 files.
          Did the same test with other files, in that case some TTF fonts and BC had the same issue. After deleted some of them in both panes, tip dissapeared.

          I hope it helps

          Thank you

          Comment


          • #6
            Re: \"Folder empty\" tip issue...

            I'm still not sure what is causing this.

            Do any grayed out folders or files show up if you turn on View|Suppress Filters?

            Do you get the same tip if you have View|Always Show Folders turned on?
            Chris K Scooter Software

            Comment


            • #7
              Re: \"Folder empty\" tip issue...

              No Chris, no grayed out files or folders show when i turn on View|Suppress Filters and i get the same tip with Always Show Filders turned on.
              Last week i've checked it with various files and setups and always had the same problem.
              Noticed that when both folders contain exactly the same files (no diff at'all) work just fine, regardless the number of files. Same, when files in both folders are all different, not event common filenames.
              When both folders contain a big number of same files with at least one changed, tip always appears.

              A simple step by step example follows...

              1. Created two folders, D:\First and D:\Second
              2. Copied 700 .INF from WinXP INF directory in both folders
              3. Compared these two folders, no tip appeared
              4. Changed a single INF contents in D:\First folder
              5. Compared folders again, tip appears
              6. Deleted some files in both folders (400 left), tip appears
              7. Deleted some more (200 left in each folder, tip appears
              8. Deleted more (100 left) TIP didn't appear

              Same results as above on three different computers with various files and folders.

              I hope it helps

              Thanks
              Sakis

              Comment


              • #8
                Re: \"Folder empty\" tip issue...

                Hi Sakis,

                From looking over your posts, I really don't know what you've found. Each tip is only supposed to display once when running BC, and then shouldn't show again until you start a new copy of it. If you check the "Don't show this tip again" checkbox it should never display.

                That particular tip will only display if you click on a folder to expand it, either by double clicking or by selecting the "Open" or "Open all subfolders" menu items. Neither comparisons or deleting files should trigger it; I've gone through the code and I honestly can't find any way for them to trigger it even if there were a subtle bug present. As you may have guessed we haven't been able to repeat the problem here either.

                If you have time, about the only thing I can think of that might help us track this down is this:

                Load a pair of folders that are causing the problem and save snapshots of each side using the "Save Snapshot" command. Load the snapshots and see if the problem still shows itself. If it does, email a copy of both snapshots and the Help|Support zip to [email protected]
                Zoë P Scooter Software

                Comment


                • #9
                  Re: \"Folder empty\" tip issue...

                  Hi Craig,

                  Tip appears even when compare snapshots.
                  Mail sent

                  Thanks

                  Comment


                  • #10
                    Re: \"Folder empty\" tip issue...

                    You are really FAST tracking bugs (less than an hour)
                    New build works excellent.

                    Thanks for your help

                    Comment

                    Working...
                    X