Announcement

Collapse
No announcement yet.

Sync Preview says: 'Nothing to do!'

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sync Preview says: 'Nothing to do!'

    I want to sync a folder through FTP (Unix) and a local folder (Windows) through the gui. After the comparison, BC shows me the folders that are different, but when I click on Sync Left -> Right (FTP -> Windows) the Syncronize Preview window says 'Nothing to do!'.

    Confused in Rochester

  • #2
    Re: Sync Preview says: \'Nothing to do!\'

    What comparison criteria are you using?

    The default sync options only copy files over if they are newer. If you are using criteria other than timestamp, the files can show as different because of other criteria, but they won't copy if the timestamp isn't newer.

    You can change this behavior in the Sync Options section of Tools|Options. If you set the If files are different option to Copy left to right. This will copy files that mismatch on criteria other than timestamp.

    If you just want the sides to be made identical, you might want to use the Actions|Sync|Custom Sync Mirror command. Mirror will make the other side identical, including deleting orphan files on the target side.
    Chris K Scooter Software

    Comment


    • #3
      Re: Sync Preview says: \'Nothing to do!\'

      A further thought.

      When copying from Windows to Unix, the files are probably changing line ending formats. This will result in a size difference, even though the files may be the same in all other respects.

      You can get around this by setting all transfers to binary, which may confuse some text editors.

      You can also use a rules-based instead of size based comparison to look at the contents of the files. This will be slower though because the entire file must be downloaded from the ftp site for a rules-based comparison.

      The simplest option is to only use timestamp criteria as long as the ftp server supports timestamps correctly.
      Chris K Scooter Software

      Comment


      • #4
        Re: Sync Preview says: \'Nothing to do!\'

        We changed the default a while ago, but this may be due to your sync settings. Go into the Options dialog, switch to "Sync Options", and uncheck the "Only affect visible files" option. If that's checked the sync only affects files that are visible in the list, which excludes files that have been filtered out and those in closed subfolders.
        Zoë P Scooter Software

        Comment


        • #5
          Re: Sync Preview says: \'Nothing to do!\'

          Thanks .. My Sync options are mostly 'Copy Left to Right' .. I unchecked "Only affect visible files" option and will test now to see if that helps .. I am copying ascii (text)files from Unix (AIX) to Windows (XP). The directory structure has many subfolders and added '-R' to the FTP LIST options. That didn't seem to work right .. Seems it displayed the child directories on AIX as parents .. weird. Using the latest BC.

          Comment


          • #6
            Re: Sync Preview says: \'Nothing to do!\'

            The -R setting has to be supported by the FTP server, and they don't all think it means the same thing, so it may just not work on AIX servers.

            If it is supposed to give recursiving listings on AIX I can try fixing BC's parsing to handle whatever it's returning. To do so you'd need to log in to your server using the command line ftp.exe and use the "list -R" command to get a listing. If you're able to do that send a copy of the listing to [email protected] and I'll take a look at it.
            Zoë P Scooter Software

            Comment


            • #7
              Re: Sync Preview says: \'Nothing to do!\'

              Craig .. Thanks .. Looks like unchecking 'Only affect Visable Files' worked .. As far as AIX .. Looks like it didn't support the -R' on the ftp list command

              ftp> list -R
              Invalid command.
              ftp>

              Thanks again

              Comment

              Working...
              X