No announcement yet.

SCC Integration crashes BC

  • Filter
  • Time
  • Show
Clear All
new posts

  • SCC Integration crashes BC


    I quickly skimmed the forums in hopes to find anything related to this problem. Nothing came up immediately, hence thread =)

    Anyway, I have Perforce set up w/ multiple clientspecs. The initial BC SCC Config I added was for one of the clientspecs, let's say under "C:\A". All is well until I found that BC really doesn't like it when I view files from other folders that are NOT found under the SCC root "C:\A" For example, "C:\B" would bring up lots of complaints from BC. "C:\B" is also the root of one of my alternate clientspecs.

    Not a problem, I'll just try adding another SCC Config to include "C:\B". When I open up the Source Control->Add window, adding a new SCC Entry hangs BC until I had to terminate the process.

    This may have been because BC was still pointing to an old folder I had deleted much much earlier, say "C:\C". In other words, bringing up BC with "C:\C\SomeFolder" and "C:\C\SomeOtherFolder" would duplicate this.

    Ok, so I quickly manage to change the initial BC folders (Left/Right pane) to my existing SCC Root ("C:\A") and again try to add a new SCC Config to the list. This time, I can actually get past the "Pick your provider" dropdown. I chose Perforce, hit ok. The next window was (I think) the Username / server / etc window. I see the labels, but the input boxes are completely gone. Not only that, the window got stretched across both my monitors and then some (to the right). I had to drag the window to the left for about three minutes before I found the rightmost end of the window. Still no input boxes. I hit "tab" and "enter" hoping to hit an OK button I saw at the left-most border of the window. The window goes away, but the SCC Config that I added has no SCC provider bound to it. Any attempt to config it brings up the same gigantic window that stretches across my monitor and then some.

    So now I have the following in my SCC list:

    Directory / Project

    C:\A / Perforce
    C:\B /

    Any ideas?

    Here's my steps a bit more concisely:

    (1) Create a clientspec in perforce with root C:\A
    (2) Create another clientspec in perforce with root C:\B
    (3) Create a folder C:\C
    (4) Open BC, and have it open C:\C in both folder-compare panels.
    (5) Add a SCC Config that points to C:\A as a Perforce project.
    (6) Close BC and delete C:\C
    (7) Open BC. BC should complain that C:\C is not found. Ignore this.
    (8) Tools->Options->Source Control->Add and try adding C:\B as a project. BC should hang.
    (9) Close BC. Reopen BC and remap the folder comparison panes to C:\A.
    (10) Try adding C:\B again as a SCC project. You should be able to choose Perforce as your project. Next window that comes up should be sans-input fields.

    (11) If you hit "config" on the C:\A project BC should hang.


    Edit : Clarified details and added steps that should repro

  • #2
    Re: SCC Integration crashes BC

    Are the repositories for c:\a and c:\b on the same server, or are they separate servers?

    Are you using the latest Perforce, 2005.2? Do you have the Perforce Core and Perforce P4Win components installed? Or just the core?
    Chris K Scooter Software


    • #3
      Re: SCC Integration crashes BC

      Hi there,

      Sorry I have not responded earlier -

      A and B are on the same server. We are using Perforce 2005.1 81632.

      Perforce Core and P4Win are installed.

      Also, to add to this .. after I gave up with having multiple folders under source control, I tried to edit my only entry in the list. It comes up with a gigantic perforce properties window that spans across my screen and off to the right. There are no edit boxes present, and if I continually drag it over (to find the right edge) I just end up with the resize-tool thing (lower right hand corner of the window) that lets me resize vertically, but not horizontally.