Announcement

Collapse
No announcement yet.

File Format not being run for files with .xml.zip extension

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aaron
    replied
    Ah, yes. Zoe's suggestion is the mask you need if you need to match on a file within the archive and it actually is an archive. My workaround is for if it is a .txt file that has been renamed to .xml.zip, and isn't actually an archive. Depending on your data, one method or the other will work.

    Leave a comment:


  • Zoë
    replied
    File format masks can include path information if they need to. You'll still have to load it as a folder first, unless you follow Aaron's advice, but if you do expand the zip in the directory compare you can still match your file format with a mask like this:

    *.xml.zip\...\*.xml

    Leave a comment:


  • Aaron
    replied
    Hello,

    With our current support, you would have to use a Folder Compare session with the Session Settings, Handling tab, Archives treated as File always option enabled. This would treat all .zip as files, and would then allow the file format mask to open the file in the associated viewer. Otherwise, matching an archive mask is a higher priority than the format mask, making it an Archive/Folder, which prevents it from opening in the file view. There isn't a method to override that other than the Session Setting option, or remove *.zip as an archive mask for Zip files.

    Leave a comment:


  • File Format not being run for files with .xml.zip extension

    Hi there, I've developed a File Format to allow me to compare UML model files. Depending on which tool they came from they can have one of three possible extensions:
    • *.zargo
    • *.xmi
    • *.xml.zip


    Now the *.zargo and the *.xmi files pick up just fine, but the *.xml.zip ones open in a regular directory view. My guess is that the filter matching *.zip as a compressed file is kicking in before the File Formats rules.
    To make matters slightly more difficult, the one file inside the *.xml.zip just has a .xml extension, so there's nothing I can match on inside the zip to get my file format invoked from there.

    Does anyone know of a way to work around this. I've only tested in BC3, as my company are yet to move to BC4, but if there's a way of solving it there, I'm all ears

    Thanks

    Barny
Working...
X