Announcement

Collapse
No announcement yet.

cannot recognize unicode txt file.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • eightbit
    replied
    Yes, I am using Windows XP english version with Service pack 3,
    and any Microsoft upgrade patch was not installed.
    and Other systems are installed Windows XP korean version with Service pack 2 or 3.
    Last edited by eightbit; 18-Aug-2008, 07:50 PM.

    Leave a comment:


  • Erik
    replied
    You're using Windows XP or earlier, right? With your file, we were able to determine that Windows XP has a threading bug in codepage detection. We've come up with a workaround for BC3.0.3.

    Leave a comment:


  • Erik
    replied
    Can you send the problem file to [email protected]?

    Thanks,

    Leave a comment:


  • eightbit
    replied
    it's another problem.

    this korean text file is recognized with 'ANSI'.
    but sometimes Turkish (Windows) or Chinese...

    I tried to compare two same file,
    and after open session, repeat press F5 20~30 times.
    i can see that 'ANSI' changes to others.

    but in the another system, that symtom is happened just 1 time.
    I think bc3 handles garbage variables...

    please check the program.
    ah. i am using bc3 ver 3.0.1
    thank you.

    Leave a comment:


  • Chris
    replied
    When BC3 opens files, it will check to see if the file extension matches a format defined in Tools > File Formats. If there is a matching format, it will open it in the viewer defined by the format (Text Compare, Hex Compare, etc). If the file extension doesn't match a defined format, it will try to determine if the file is binary or text and open it in the Hex Compare or Text Compare.

    To force your Unicode files to open in the Text Compare, define a new Text Compare file format that matches the extension of your files.

    Just the Unicode header alone isn't enough to make BC3 open files as binary, so it might be some other value in your files. If you can share the files, please send a copy to [email protected] and we'll look into it.

    For files that aren't Unicode or Utf-8, BC3 will try to detect the character encoding, but if it fails you can manually select a character encoding. You can select a quick list from the File Info bar at the top of each pane. You can also select an encoding override for each file in the Format tab of the Session > Session Settings dialog.

    Leave a comment:


  • eightbit
    started a topic cannot recognize unicode txt file.

    cannot recognize unicode txt file.

    i tried to compare two files, one is unicode text and other one is ansi text.
    but bc3 always works in binary compare mode.
    (bc2 works good.)

    i think bc3 cannot recignize unicode text header '0xff 0xfe'


    and bc3 sometimes confuse text encoding type.
    i read a text file written in korean language, (not unicode)
    bc3 decided to 'western europian (windows)' and characters are broken.
Working...
X