Announcement

Collapse
No announcement yet.

Format Rules Revisited

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Format Rules Revisited

    Hi All,

    I'm using 3.1.11 (build 12204).

    I've got a special rule for a particular file-extension, but files with that extension do not appear to be using the rule.

    I have the understanding that 1) "Session Settings" control which grammer items have significance and 2) "Session Settings" only pertain to a pair of files. Is this true?

    If so, it's a major pain and departs from BC2's approach which was workable.

    How do I go about setting up my environment such that ALL files with my extension have the correct comparison rules applied?

    Thanks in Advance,

    Carl <|};-)>

  • #2
    Hello Carl,

    The last step you probably need is to set Session Setting Defaults, rather than just a single session setting.

    It is true that Grammar items are now part of a global File Format (Rule). You can see which file format is used in the top status bar of each pane; the file format and detected encoding are displayed here. Each pane can potentially use a different file format, but most commonly it will use the same on both sides.

    The Importance of these grammar items is session based, but there are session defaults. For example, Comments can default to be unimportant, but set for specific sessions to be important. Your current grammars are probably defaulting to the opposite behavior you desire.

    Go to the Home screen, and expand the green Edit session defaults folder located at the top of your Saved Sessions list. Select the Text Compare and edit the Importance tab. Checked items are important, Unchecked are Unimportant.

    Here is a KB article that goes into more detail:
    http://www.scootersoftware.com/suppo..._unimportantv3

    Please let us know if you have any questions.
    Aaron P Scooter Software

    Comment

    Working...
    X