No announcement yet.

Class comparison fails when BC3 Pro installed on a share

  • Filter
  • Time
  • Show
Clear All
new posts

  • Class comparison fails when BC3 Pro installed on a share


    I've installed BC3 Pro on a shared directory. The installation contains the class file format helper. I want to install it on a shared directory so that another application can launch comparisons that use BC3. (and we have a site licence, so I don't care about how many users are using it).

    When I compare jar files with this installation, the decompilation fails. However the same comparison when I launch BC3 locally is sucessful.

    I tried to install BC3 locally then copy-paste it on the share, or install BC3 as a portable install and then copy-paste it on the share: the problem remains.

    I also tried to change the path to the helper ("CLASS_to_JAVA_tidied.bat") to an absolute path, but the problem remains.

    Thanks for your help :-)

  • #2

    A Portable Install should be able to use the file format and conversion script. Please try the absolute path with quotes, just to make sure whitespace is not causing an issue. What is the exact error message you are seeing?

    It may also be an issue of user permissions and executing script or bat files from a network share. Are you able to manually execute the command line in the Conversion tab from the Windows Command line? You can pass in a test file instead of %s, and use "c:\temp.txt" instead of %t.
    Aaron P Scooter Software


    • #3
      Hello Aaron,

      Thanks for your answer :-)

      I tried with a brand new portable install. There are no whitespaces in the absolute path to the helper .bat file.

      Anyway, I'd still like to use a not-portable install, so that the session informations stay on the local machine of my users and are not shared between them. For many kinds of comparisons, the setup with the normal install works perfectly.