Announcement

Collapse
No announcement yet.

compare on z/os mainframe

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    I'm going to jump in here, since I found this entry via a search. I'm a long time user of BC and have always extolled its virtues to everyone.
    I'm now working on a new contract at a company and am using BC4.4.2 via a USB drive, so in the same way, I want to be able to compare
    files on the mainframe with those in Windows.
    I followed the instructions above (I think) up to and including Chris' comment of 10:48 PM, and my results look like this

    Click image for larger version

Name:	image.png
Views:	38
Size:	66.7 KB
ID:	88561
    My memory says that earlier versions of BC were simpler to use for mainframe/windows comparisons.
    For example, didn't BC earlier have an option to download the mainframe file and detect the record length automatically before comparing it with the PC version, thus negating the need to know
    the record length of the mainframe file???

    The basic problem I'm having is the ability to define a session whereby once side is always ANSI, and the other, preferably, downloads the mainframe file and uses ANSI as the conversion code (?).
    Like I say, my memory says that BC3 was much easier to get the comparison between mainframe files and PC files working correctly.



    I then read Aarons' reply of 08:25 PM and tried that. This is my profile (and I exited BC before trying again). This is what happened when I specified the mainframe PDS

    Click image for larger version

Name:	image.png
Views:	17
Size:	54.2 KB
ID:	88562

    Here is my profile

    Click image for larger version

Name:	image.png
Views:	17
Size:	15.9 KB
ID:	88563
    Last edited by misi01; 15-Aug-2022, 07:17 AM.

    Comment


    • #17
      Using ASCII transfers rather than binary transfers might resolve the mainframe issue. According to our lead developer, when using ASCII transfers the server might handle converting from EBDIC to ANSI and insert line breaks.

      Beyond Compare's default settings use Auto for FTP/FTPS/SFTP transfers, meaning that file extensions that are known text files transfer in ASCII mode, other file extensions transfer in binary. Since your mainframe files don't have an extension, they're probably using binary transfers.

      To change the transfer type from Auto to ASCII:
      Select Tools > Profiles from the menu.
      Select the profile of your server or the <default> profile.
      Go to the Transfers tab.
      Change Transfer type from Auto to Binary, then Save.
      Chris K Scooter Software

      Comment


      • #18
        Okay. The answer that seems to work for me was not to use Transfer type Binary but rather ASCII, then it seemed to be okay.
        Thanks for the help (thank goodness I had BC3 as well, so I could compare my settings)

        Comment

        Working...
        X