Announcement

Collapse
No announcement yet.

File size column not showing sizes > 1kB

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • File size column not showing sizes > 1kB

    [Build 444, Vista x64]
    Today I noticed all file sizes > 1kB don't seem to appear in the Size column.
    I can't remember if it has worked before and I just didn't notice it.
    Known issue?

  • #2
    File sizes are working for me. What type of folders are you comparing?
    BC v4.0.7 build 19761
    ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

    Comment


    • #3
      Originally posted by Michael Bulgrien View Post
      File sizes are working for me. What type of folders are you comparing?
      It doesn't seem to matter which folders I compare, attached is a screenshot of Windows\System32 <=> Windows\SysWOW64.
      Last edited by ; 28-Jan-2008, 01:10 AM. Reason: Fixed attached picture.

      Comment


      • #4
        If you haven't already tried it, I would increase the width of the Size column to see if that fixes the problem. Of course if that's the problem then there should probably be ellipses (...).

        Comment


        • #5
          Originally posted by Pete View Post
          If you haven't already tried it, I would increase the width of the Size column to see if that fixes the problem. Of course if that's the problem then there should probably be ellipses (...).
          Nops, the size of the the column doesn't matter unfortunately.

          Comment


          • #6
            What is that "Unable to load files" message in your log messages? If Cirrus can't read the files, for whatever reason, that could explain its inability to report certain file attributes.
            BC v4.0.7 build 19761
            ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

            Comment


            • #7
              Originally posted by Michael Bulgrien View Post
              What is that "Unable to load files" message in your log messages? If Cirrus can't read the files, for whatever reason, that could explain its inability to report certain file attributes.
              That was just some system file (something like 'Unable to load file Yada.dat').
              During normal folder compare sessions I don't see any errors at all.

              Comment


              • #8
                On my system, if the column is not wide enough to show the file size, then an ellipsis (…) is displayed. Your screenshot doesn't even have that. Weird.
                BC v4.0.7 build 19761
                ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

                Comment


                • #9
                  This might be a Windows Vista specific behavior because the folders in the screen shot are system folders.

                  Does it help if you right click on the Cirrus shortcut and start it using "Run As Administrator"?
                  Chris K Scooter Software

                  Comment


                  • #10
                    Originally posted by Chris View Post
                    This might be a Windows Vista specific behavior because the folders in the screen shot are system folders.

                    Does it help if you right click on the Cirrus shortcut and start it using "Run As Administrator"?
                    It doesn't seem to matter which folders I compare.
                    Nope it doesn't help using "Run As Administrator" on the cirrus shortcut and then choosing any folder compare session I have saved.

                    Comment


                    • #11
                      Backup and delete settings

                      If you backup and delete your current settings, does the problem continue to be present with the default settings?

                      To delete, go to AppData/Scooter Software/Beyond Compare 3/xmlfiles
                      or, if you are in single directory mode, the xml files are in the install directory. Cut them out and place them in another location.
                      Aaron P Scooter Software

                      Comment


                      • #12
                        Using default settings didn't help. Neither did installing the new build from yesterday.
                        Note that it show the file sizes for size < 1kB.
                        Maybe some bug you have when converting the "1234" to e.g. "1.2kB" in Vista?

                        *Edit: I have customized Swedish locale, using "." as a decimal rather than the Swedish standard ",". Maybe it has something to do with localization of numerics? (If you do any).
                        Last edited by ; 14-Feb-2008, 01:08 AM.

                        Comment


                        • #13
                          I have customized Swedish locale, using "." as a decimal rather than the Swedish standard ",". Maybe it has something to do with localization of numerics?
                          That's it! We're able to repeat the problem here and should be able to fix it.
                          Tim T Scooter Software

                          Comment

                          Working...
                          X