Announcement

Collapse
No announcement yet.

3.0.1, 3.0.2 much slower on source control

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 3.0.1, 3.0.2 much slower on source control

    Hi All,
    It seems like there is a regression in BC3.0.1 which is not fixed in 3.0.2. The folder comparation on source control location is much slower (the folder list appears only after couple of minutes). If the same folder is removed from the list of source controlled folders all works fine.
    Probably the reason in reading of some extended attributes for the source controlled files.
    I've rollback to 3.0.0 - all works fine.

  • #2
    The behavior is similar like described in this post http://www.scootersoftware.com/vbull...ead.php?t=3748 - the button is blinking and the comparation cannot be stopped.

    Comment


    • #3
      You didn't say what source control provider you're using, or whether 3.0.0 actually worked correctly. If you show the "Status" column does it fill in correctly in both 3.0.0 and 3.0.2?
      Zoë P Scooter Software

      Comment


      • #4
        I'm using Rational Clearcase for source control.
        Status field is in both versions shows status as controlled for checked in files.
        For checked out files BC3.0.0 shows "checked out". BC3.0.2 leaves field empty.

        Also following bug was observed in BC3:
        1. Open file comparation. One file is source controlled.
        2. Move to difference.
        3. Press move changes from not controlled file to other one.
        4. In the dialog press "yes", to checkout the file.

        After checking out difference is moved, but the dialog "File changed, do you want to reload" is appeared. In BC2 dialog didn't appear for this scenario. Imho it more user friendly.

        Comment


        • #5
          Hi. I've just checked, the problem is still reproducible with BC 3.0.4

          Comment


          • #6
            Mishko,

            We fixed a bug with ClearCase in 3.0.5, so I'd suggest trying that to see if it works any better. Other than that, I checked the changelog for 3.0.1 and couldn't find any changes that would have introduced the problem you're describing. There were some changes to the source control integration late in the beta, but they were all finished by the 3.0.0 release. Are you sure that's the version you rolled back to?
            Zoë P Scooter Software

            Comment


            • #7
              Craig,

              I've tested 3.0.5 release, the problem is still reproducible.
              The build which works fine for me is 3.0 build 8507.

              Comment


              • #8
                This is a stretch, but do you have content comparisons on? If so, can you try starting a new comparison with them disabled?
                Zoë P Scooter Software

                Comment


                • #9
                  Hi Craig,

                  I've tried to turn content comparation off - the result is same - it's too slow.

                  Comment


                  • #10
                    Hi Craig, All,

                    I've tried BC 3.0.10 - all works fine. Thanx for the great tool.

                    Comment

                    Working...
                    X