Announcement

Collapse
No announcement yet.

BC3 Report Title Special Characters

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BC3 Report Title Special Characters

    Hi

    I perform a number of comparisons via batch commands and then as part of the process sftp the report txt file to a unix box for additional processing.

    BC3 txt reports have special characters inserted at the begining of the title line, prior to the title:-

    rep_test

    BC2 did not insert these characters. Is there an option or switch I have missed, which could stop these.

    My infile look like this:-
    #Compare Script for rep_test

    #create log file
    log verbose "D:\BC3\BC3_logs\rep_test_log_%date%_%fn_time%.txt "

    #specify comparison criteria
    compare binary

    #load app session
    load "rep_test"

    #specify output criteria for normal report which is sent to libman
    folder-report layout:summary options:display-mismatches,column-crc,column-size,column-timestamp &
    title:rep_test &
    output-to:\BC3\BC3_REPORTS\rep_test.txt

  • #2
    Hello,

    Are you running the script on a Windows machine? Do the special characters appear when you open the text file before transfering it to the Unix machine? Are the two reports binary equivalent after the transfer?

    If you transfer as Binary instead of ASCII, does that help with the characters? (Tools menu -> FTP Profiles -> Transfer tab -> Transfer type).
    Aaron P Scooter Software

    Comment


    • #3
      Those characters are the UTF-8 byte order mark, and no, there's no way to keep them from getting written. Here's a short Perl script that will strip them (reads from stdin, writes to stdout):

      Code:
      #!/usr/bin/perl
      @file=<>;
      $file[0] =~ s/^\xEF\xBB\xBF//;
      print(@file);
      Zoë P Scooter Software

      Comment

      Working...
      X