Announcement

Collapse
No announcement yet.

SFTP connection error with public/private keys (between EC2 and mac)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SFTP connection error with public/private keys (between EC2 and mac)

    I've successfully connected to a number of servers using SFTP in BC4 on my macbookpro. I'm trying to get a new server to connect but it won't.

    These things work:
    1) On command line "ssh myserver" (I have a section of the .ssh/config file with the credentials and the private key)

    2) In FileZilla, I added my private key (after converting it to a ppk format) and successfully created a profile.

    3) In BC4, I have configured a different server the same way and it works for that server. I compared the profiles and I don't see any difference.

    The only difference I can see between the servers is that one is CentOS 5 and the other is a newly created server on EC2 and is CentOS 7.

    The error I'm receiving when trying to connect is:
    Public key authorization failed.
    Public key agent authorization failed.
    No more authentication methods available.
    Connection failed: Connection list (error code is 10058)

    Thanks for any clues about why BC4 would act differently from FileZilla and what I should try next.

    (I saw a similar thread from a couple of years ago, but it appeared like that was on a PC, since it recommended installing Pageant. I'm not sure how I would do that on a Mac or if that's relevant.)

  • #2
    Hello,

    Are you using the latest BC4 (4.0.3) release for testing? We have also sometimes seen odd issues with specifically generated key pairs. If you generate a new pair for testing, does the new pair allow the connection?

    Also, when making any changes to the specific SFTP Profile or the <Default> Profile in the Profiles dialog, please then restart the application. This is not always necessary, but is a useful troubleshooting step to be certain the new changes are applied on connection.
    Aaron P Scooter Software

    Comment


    • #3
      Yes, the first troubleshooting I did was download the latest version (build #19420) .

      I did try quitting BC and starting it up again. No luck.

      And I did generate a new pair -- I received one from Amazon when I created the server, then I generated one on my Mac when that didn't work. I wondered if the key was a different type or something.

      Comment


      • #4
        Paulie,

        Thank you for reporting the issue, I've repeated the problem.

        I verified connecting to an SFTP server using a private key fails if the server is running CentOS 6.6, and it works with a server running CentOS 5.11. This was true for both BC 3.3.13 and BC 4.0.3.

        OpenSSH has had quite a few security patches recently, so it's possible one of the recent patches in newer versions of OpenSSH introduced a compatibility issue.

        I've added this to our bug list and we'll work on fixing this for an upcoming release.
        Chris K Scooter Software

        Comment


        • #5
          I just tried this again with Build #19477 and it connected!

          Thanks so much for the great support and the even greater product!

          Comment


          • #6
            Hello,

            We have a couple of fixes in the latest 4.0.4 release, but if other users are still having trouble, we have a few more coming in the next 4.0.5.
            Aaron P Scooter Software

            Comment


            • #7
              For anyone else having trouble with SFTP private key authentication, I've added an article that describes the process to our website:
              Beyond Compare is a multi-platform utility that combines directory compare and file compare functions in one package. Use it to manage source code, keep directories in sync, compare program output, etc.


              The steps in the above article worked in testing with BC 4.0.4 Pro for Windows as a client using a private key without a passphrase and RHEL/CentOS 5.11, 6.6, and 7.0 on the server end.
              Chris K Scooter Software

              Comment

              Working...
              X