No announcement yet.

SFTP support via a jump host

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    The cleanest example I've seen of this is in WinSCP's ability to tunnel to any connection. DEinspanjer's work-around is fair, and I'm sure one could automate it to a degree, but this IMO is not quite worth the "PRO" money. Scooter keep up the good work, but it's been about 6 years since this request came in, what would it take to get this in?


    • #17
      Another [long-time 10+ years) user here of BC... please re-consider adding the ability to connect over SSH via a jump host.


      • #18
        It's still on our wishlist, but a large project. BC4 still requires the helper applications to create the tunnel.
        Aaron P Scooter Software


        • #19
          Hello DEinspanjer,

          >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> >>>>>>>>>>>>>>>>>>>>>>>>>>>>
          Originally posted by DEinspanjer View Post
          I'd like to second the request for SSH jumphost support. It seems it could be added pretty easily in the existing Proxy tab. Just need to offer a new type called SSH Jumphost and add the SSH private key file field that you have in the Login tab.

          Would be great, and it is about time for me to buy another license to support your fantastic product.

          In the interim, here is what I found to be the easiest way to get it working:

          1. Create an FTP profile for the destination host as you would if there wasn't a jumphost in the way. Use the hostname that you would use from the context of the jumphost. (i.e. if it has an internal hostname that your desktop machine can't normally resolve, use that internal name)
          2. On the Proxy tab, uncheck Use default
          3. Check Use proxy
          4. Set the Proxy type to "SOCKS 5"
          5. Enter "localhost" as the Host
          6. Leave the Port set to "1080"
          7. Leave the Username and Password blank.
          8. Save this FTP profile

          9. Before using the FTP profile you just created, open a connection to your jumphost as a SOCKS proxy.
          9a. For the command line OpenSSH utility, connect to your jumphost using the argument "-D 1080" (e.g. ssh -D 1080 )
          9b. For a GUI SSH program, look for an option in the connection configuration called SOCKS proxy.
          >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> >>>>>>>>>>>>>>>>>>>>>>>>>>>>

          This worked for a while, then something changed, now I get this error:
          "bind []:1080: Permission denied"
          "channel_setup_fwd_listener_tcpip: cannot listen to port: 1080"
          "Could not request local forwarding."
          I know my password is correct, because I can login to putty with it.