No announcement yet.

Extremely high CPU usage during SFTP uploads

  • Filter
  • Time
  • Show
Clear All
new posts

  • Extremely high CPU usage during SFTP uploads

    BC3 459
    Windows XP Pro SP3

    I have BC3 set to use up to 4 threads. I was trying to upload a total of 60 files. The entire time the upload was taking place, BCompare.exe had my CPU pegged at between 85-100%. It rendered my system unusable.

    I know that SSH adds overhead, but this is not normal behavior.
    Last edited by tired; 23-Jun-2008, 09:11 PM.

  • #2
    A similar CPU-eating type of behavior occurs when I download using FTP. That is, when I do binary compares with one side being the FTP server. I can't even focus the BC3 window (not responding) and it's devouring 100% CPU.


    • #3
      I'll profile our SSH code and see if there's hotspots that stand out. The SSH encryption can add quite a bit of CPU overhead though; have you tried using 4 simultaneous SSH connections in any other program?

      What are the specs for your system, what kind of connection do you have to the server, and what size/quantity of files are you transferring?

      You can lower the priority of the threads used for comparisons in the Tweaks dialog (Ctrl+Shift+T). That will affect the binary comparisons, but won't have any effect on the SSH transfers.
      Zoë P Scooter Software


      • #4
        I have an AMD Athlon 3000+ which is 2.1 GHz, and 2-GB of RAM. Running on WinXP Pro SP3.

        I've uploaded the exact same types/sizes of files using FileZilla 3.0.11 with 4 threads, using SSH. FileZilla does not cause excessive CPU usage at all.

        Just now I ran another test using FileZilla, uploading many ~2-MB files in 4 threads. FileZilla launched 5 instances of fzsftp.exe (why 5 rather than 4, I don't know), and the CPU usage for all of them combined is extraordinarily low, from what I'm seeing in Process Explorer. I watched for a minute or so while the uploads were going, and what I'd see is a blip of 1.54% CPU (yes, that's one-point-fifty-four percent) from one process at a time, every 10 seconds or so. Then after another 10 seconds, roughly, one process would jump to ~3%. The remainder of the time, all 6 processes (5 fzsftp.exe and filezilla.exe) were not using meaningful CPU time at all.

        An older version of WinSCP had an issue with high CPU usage as well (though not as bad as I'm seeing with BC3). Then, a beta of WinSCP came out and that issue was gone completely. What I'm saying is that I've used WinSCP with SSH, with this same server and the same types of files, and not had it use much CPU.

        I'm uploading with 4 threads (max), several hundred files in a batch, sized typically around 50 KB to 5 MB. My upload speed is abysmal, and at max is 24 KB/s. If I remember correctly BC3 reported much lower speeds than that (in the log).

        I'm convinced that it's not normal at all for SSH uploads to grab the entire system by the throat, especially since I can upload the same files without a problem, using FileZilla.


        • #5

          One other thought: are you running the release build or the debug build of BC3? For speed/optomization testing, the release build should be used. For most other testing the Debug build is useful for detailed crash reports. You can simply install over the pre-exisitng install (like an update) to switch between the two if necessary.
          Aaron P Scooter Software


          • #6
            I've used both the full debug version and the optimized version, and this issue occurs with both of them.


            • #7
              In your FTP profile switch to the "Connection" tab and try changing the "Read timeout" property to "0". I'm looking into it further but as far as I can tell that's the problem.
              Zoë P Scooter Software


              • #8
                Today's release (build 460) should have this fixed. Let me know if you're still seeing any problems.
                Zoë P Scooter Software


                • #9
                  Will a CPU of 1066 fsb run on a motherboard that has a bus speed of only 800mhz? I'm planning on buying a new CPU in order to upgrade from my Intel Core2Duo e4300 (1.8 Ghz) which runs at 800mhz FSB. But the new CPU (intel 6600) says that it runs at 1066 FSB and my motherboard only runs up to 800Mhz.


                  • #10
                    Hello Sujanne,

                    These discussion forums are for discussing Beyond Compare software. For hardware questions you should post your question on a discussion forum for the manufacturer of your motherboard, or a hardware discussion site like Anandtech or Tom's Hardware.
                    Chris K Scooter Software