Announcement

Collapse
No announcement yet.

FTP issues with IBM z/OS mainframes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FTP issues with IBM z/OS mainframes

    When I try to use the FTP feature, I've found an issue when working with IBM z/OS mainframe systems. These servers have the ability to expose both their UNIX-style file systems as well as classical datasets to the FTP server. Unfortunately, BC3 makes an invalid assumption about the naming style of the datasets, rendering it impossible to work with them via FTP.

    If I wanted to work with the POSIX dataset, I could use a command line FTP client and issue the command cd 'POSIX'. If I try to sync with this folder, BC3 incorrectly inserts a slash character before the dataset name, causing the server to reject it. Take a look at the FTP log:

    Code:
    8/15/2008 8:55:17 AM  Username: THINKMOO2\agiorgio
    8/15/2008 8:55:35 AM  Stat> Connected.
    8/15/2008 8:55:35 AM  Recv> 220-FTPD1 IBM FTP CS V1R10 at xxxxxxxx, 08:55:37 on 2008-08-15.
    8/15/2008 8:55:35 AM  Recv> 220 Connection will close if idle for more than 100 minutes.
    8/15/2008 8:55:35 AM  Sent> USER xxxxx
    8/15/2008 8:55:35 AM  Recv> 331 Send password please.
    8/15/2008 8:55:35 AM  Sent> PASS ********
    8/15/2008 8:55:36 AM  Recv> 230 XXXXX is logged on.  Working directory is "/u/xxxxx".
    8/15/2008 8:55:36 AM  Sent> FEAT
    8/15/2008 8:55:36 AM  Recv> 211 no Extensions supported
    8/15/2008 8:55:36 AM  Sent> TYPE I
    8/15/2008 8:55:36 AM  Recv> 200 Representation type is Image
    8/15/2008 8:55:36 AM  Sent> SYST
    8/15/2008 8:55:36 AM  Recv> 215 UNIX is the operating system of this server. FTP Server is running on z/OS.
    8/15/2008 8:55:36 AM  Sent> PWD
    8/15/2008 8:55:36 AM  Recv> 257 "/u/xxxxx" is the HFS working directory.
    8/15/2008 8:55:40 AM  Sent> CWD 'POSIX'
    8/15/2008 8:55:40 AM  Recv> 250 "POSIX." is the working directory name prefix.
    8/15/2008 8:55:40 AM  Sent> PWD
    8/15/2008 8:55:41 AM  Recv> 257 "'POSIX.'" is working directory.
    8/15/2008 8:55:45 AM  Sent> CWD /'POSIX.'
    8/15/2008 8:55:45 AM  Recv> 550 CWD cmd failed : EDC5129I No such file or directory. (errno2=0x05190050)
    8/15/2008 8:55:45 AM  Unable to load 'POSIX.': CWD cmd failed : EDC5129I No such file or directory. (errno2=0x05190050)
    If I do this from the command line, I can get these results:

    Code:
    ftp> cd 'POSIX'
    250 "POSIX." is the working directory name prefix.
    ftp> cd 'YACC'
    250 "YACC." is the working directory name prefix.
    ftp> pwd
    257 "'YACC.'" is working directory.

  • #2
    I worked with Chris on getting MVS to work during the beta of BC3. I don't have the production version of BC3 (I'd would love to have it! ) but when I last used the beta, MVS was working. Are you able to do any compares on MVS at all?

    Comment


    • #3
      I believe that I didn't have any problems doing compares with files that are in the normal UNIX file system (HFS) on z/OS. However, the source code for my current project is mirrored in a classical data set, and I'd love if BC was able to do a compare based on that file. If the FTP support was tweaked a little bit, I could do all my code review compares without having to manually FTP the files to my workstation.

      Comment


      • #4
        I'm sorry, I'm only familiar with using MVS on z/OS, not UNIX. I'm able to compare partitioned data sets on MVS just fine.

        Comment


        • #5
          I know this is an old thread, but I thought I'd update anyway with what worked for me (both MVS and HFS/Unix files on z/OS):

          MVS 'folder' example: ftp://[email protected]/'VPT.TN.PERFOUT'
          HFS/Unix 'folder' example: ftp://useri[email protected]//u/cicsts/cics380/

          Comment

          Working...
          X