No announcement yet.

SFTP with freesshd

  • Filter
  • Time
  • Show
Clear All
new posts

  • SFTP with freesshd

    I'm connecting to a freesshd server 1.2.1 ( running on windows server 2003. I'm able to list remote repositories without any problems. I'm also able to view remote files for comparisons.

    But when I'm trying to upload remote files, beyond compare start with the first file upload (which succeed) and then the remote freesshd daemon service crash without any notification. It's as it doesn't like a command that is made at the end of a file upload.


  • #2
    Hi Sebastien,

    I can't reproduce this issue here. How big are the files you're transferring, and are they ASCII or binary? Have you tried reporting the same issue to the freesshd guys?
    Zoë P Scooter Software


    • #3
      Hi Craig,

      Thks for having looked into this. I'm still blocked on the pb. I've reported the issue to freesshd but hasn't got any answer yet.
      I'm mainly transferring small files, ASCII or binary. I know for sure it fails with small ASCII files (the last transfer I've tried yesterday). The first file is updated then the transfer fails.



      • #4
        Hi again,

        To share some more information.

        I've tried updating the same files with winscp 4.0 and it succeed. I was able to upload multiple files in sequence without any trouble.

        In the past I was also able to upload files using BC 2.x series combined with bitvise tunnelier FTP->SFTP bridge mode and it was also OK.

        So it looks like BC3 is issuing a command that feesshd doesn't like at all. Maybe it has something to do with freesshd capabilities.

        Following is what winscp tells me about the server & protocol info.

        Protocol tab:

        Session protocol = SSH-2
        SSH implementation = WeOnlyDo 2.0.3
        Encryption algorithm = aes
        Compression = No
        File transfer protocol = SFTP-3

        Capabilities tab:

        Can change permissions = Yes
        Can change owner/group = No
        Can create symlink/hardlink = Yes/No
        Can lookup user groups = No
        Can duplicate remote files = No
        Can check available space = No
        Can calculate file checksum = No
        Native text (ASCII) mode transfers = No

        The server does not support any SFTP extension.

        Maybe there can be some useful info here.



        • #5
          You've described the problem as both the daemon crashing and as the transfer failing. Does the daemon actually stop running, or does it just drop the connection and you're able to immediately reconnect? If it's the former the freeSSHD devs are really the only people that can help; if it's the later I might be able to do something if you can give me a limited login on the server. If you're able just email [email protected] with the details and I'll see if I can find anything. I still have not been able to reproduce the crash here.

          If it's ASCII transfers only, today's release may fix the problem. I added support for detecting servers that we know only run on Windows, and BC will always do binary transfers in that case.
          Zoë P Scooter Software


          • #6
            Hi Craig,

            It is the daemon that completely crashes. But now, I know which command make it crash !!!

            If I uncheck the 'preserve timestamp' option in ftp profile for my connection, I have no trouble copying files either in ascii or binary mode.

            To be sure, I've tried touching a remote file and it makes the freesshd daemon crashing as well. So for sure, it is the command that tries to update the timestamp of remote file that make it crash.

            Can you tell me which SFTP command do you use for that purpose so I can send a better detailed bug report to the freesshd team.

            Thks again for you time,



            • #7
              Thanks for the followup. I found a bit if code that could be causing the problem (still can't repeat it inhouse), and sent information on a test build to the email address you used to register in the forums. Let me know if you don't get it.
              Last edited by Zoë; 18-Sep-2008, 11:39 AM.
              Zoë P Scooter Software


              • #8
                Hi Zoë,

                after roughly 10 years of BC usage I recently purchased/updated to BC 4. I am still experiencing the above freesshd crash when uploading a file + preserving timestamp option enabled.

                Can you do anything about that, or would you say it's a bug in freesshd? In the latter case I would file them a bug report.

                Best regards,
                Ansgar / HeidiSQL


                • #9

                  Do you have a test account we could use to connect and test against the FTP server? We were never able to reproduce the issue in house, and Zoe's test build wasn't able to help for this user.

                  You can email us at [email protected] with a link back to this forum thread for our reference.
                  Aaron P Scooter Software