Announcement

Collapse
No announcement yet.

Non-standard ports ignored for FTPS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Non-standard ports ignored for FTPS

    Tried to connect to an FTPS site on port 990 using BC3.0.7_9037 (connection works seemlessly using 2 other FTP clients).
    It fails and BC tells "No connection could be made because the target machine actively refused it". Using Wireshark protocol analyser i figured out that it seems that BC is always trying to connect to port 21 and that attempt is of course refused by the server.

    Any hints how to get this running?

    Regards
    Andre

  • #2
    You should be able to use the "Browse" button or enter a URL like: ftp://[email protected]:990/

    BC3 does currently only support explicit SSL though, so if you're trying to use implicit SSL it might fail with that error message.
    Zoë P Scooter Software

    Comment


    • #3
      Don't know all the FTP details/variants. I just know that all other FTP clients I tried (which support FTPS) are able to connect to that server via ftps://[email protected]:990. Thus I created a new BC session, selected FTPS as the protocol, IP, port, username and password. BC issued the correct URL ftps://[email protected]:990. But can't connect. Sniffing IP trafic with Wireshark (prev. Ethereal) showed that BC does not use port 990 but 21 (which is the standard FTP port), thus destination server refused to reply.

      Comment


      • #4
        The next release will use implicit SSL for port 990.
        Zoë P Scooter Software

        Comment

        Working...
        X