No announcement yet.

FTP Sync Hanging

  • Filter
  • Time
  • Show
Clear All
new posts

  • FTP Sync Hanging

    Everytime I run BC3 as a windows tasks to connect via FTP and sync folders, it hangs. It copies all the smaller files, but hangs at files larger then 2GB. Please advise. Vista client connecting to MS Server 2k3.

  • #2
    If you use the application interactively, are there any clues in your log? You can turn on more log options from the Tools menu -> Options -> Folder Views: Log.

    It may just be taking a long time to perform the transfer on such a large file. How does BC3 compare to other FTP Clients, such as Filezilla or My Computer?

    You can email your log to [email protected] with a copy of your support package (Help menu -> Support; Export).
    Aaron P Scooter Software


    • #3
      The log doesn't get generated because the process never completes successfully. I have to kill BC3.exe. The actual file size is 6gb but it gets stuck at about 2gb everytime.


      • #4
        The log is both the file and the green box at the bottom of a Folder Compare. The green box should contain your connection information, and will let you/us know how you are connecting to the file (PORT vs PASV, Binary vs ASCII, etc). This information will be posted to the green box before you click Copy (as will the intial transfer command).

        How does Filezilla, My Computer, or FTP.exe handle the transfer?

        Are you running it as script via a Windows Scheduled Task, or launching the application and using the graphical interface? I strongly recommend troubleshooting the issue interactively first, before implementing via script. Script adds on a layer of complexity that can be troubleshot after we get the file to transfer successfully.
        Aaron P Scooter Software


        • #5
          Problem Fixed

          I work with FatahSyed and we were able to fix the problem on the server.

          Apparently there's a bug in the way Windows Firewall interacts with FTP connections for large files. We made a registry change described here:

          I made the registry change described:
          1. Click Start, click Run, type Regedit, and then click OK.
          2. Locate, and then click the following registry subkey:
          3. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ALG\ISV\{6E5 90D61-F6BC-4dad-AC21-7DC40D304059}
          4. In the results pane, double-click PreferExternalManifest.
          5. In the Value data box, type Disable, and then click OK.
          6. On the File menu, click Exit to close Registry Editor.

          And it started working fine for files over 5 Gig.