Announcement

Collapse
No announcement yet.

Avoid ASCII-Transfer when using Hex-Compare

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aaron
    replied
    Hello Christoph,

    Thanks for the bump. This is still on are radar and an open issue, but is not something we have been able to tackle yet.

    As a workaround, how does switching your FTP profile to use binary transfers for everything work for you?

    Leave a comment:


  • chrroe
    replied
    Hi,

    I've tried in 3.3 beta, but still the same trouble .

    Alternatively you could display a warning icon in the file-info area that it has been converted during transfer and the displayed file-size may not be correct?

    Any chance?


    Bye
    Christoph

    Leave a comment:


  • Aaron
    replied
    That is a good suggestion, Christoph. I'll add it to our Wishlist for our developers to look at.

    Thanks.

    Leave a comment:


  • chrroe
    started a topic Avoid ASCII-Transfer when using Hex-Compare

    Avoid ASCII-Transfer when using Hex-Compare

    Hi Scooter-Team,

    please take a look at the following scenario:
    On a Linux-Server there are two text-files (text1.txt with 100 bytes and test2.txt with 104 bytes) with same content, but different line endings (one has CR+LF, the other only CR).
    Now I use BC3 on Windows in order to compare the two files via (S)FTP. As expected the file compare reveals that the files are the same.
    But when I open them in Hex-Compare there should be some differences displayed due to line endings. To my surprise Hex-Compare does not show any differences and the filesize in the info pane is on both sides 104 bytes.

    After some experiments I disabled the ".txt" extension in the FTP transfer settings, so that txt files get transfered in binary mode instead of ASCII.
    A reload of both files now showed the different line endings in the Hex-Compare.

    I want to suggest, that Hex-Compare (and maybe other special compares, too) should always use binary transfer mode regardless of what extensions are set to ASCII in the FTP profiles.

    Does that make sense, or am I overlooking something?


    Bye
    Christoph
Working...
X