Announcement

Collapse
No announcement yet.

FTPS hangs after PASV

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FTPS hangs after PASV

    Hi,

    I'm trying to get FTPS (explicit SSL) working. currently i have the pro version 3.1.10.11626 (current build).

    normal, ie un-secure FTP works. when i change it to FTPS, it goes through the login and then hangs up on the PASV command.

    So, looking at the dialog. BC issues AUTH TLS, which is accepted with 234, then it logs in and issues PBSZ 0 (response 200), then PROT P (200 again), then we get PASV. the response is a valid IP and port, but then nothing. BC is flashing its "waiting" button. eventually, it times out and starts over.

    any ideas?

    i tried active mode, but this doesnt work due to the firewall NAT.

    - hugh.

  • #2
    Hi Hugh,

    You'll need to check the "Clear control channel (SSL only)" optoin on the "Connection" tab. After connection and authentication that unencrypts the connection the commands are sent on, which allows your firewall to parse it and handle the data connection. The initial login is still encrypted, so your password never goes out unencrypted.
    Zoë P Scooter Software

    Comment


    • #3
      Arg! i get "CCC, 500 unknown command", and therefore no difference.

      i must be connecting to lameftpd or something :-)

      Randomly, i tried issuing AUTH SSL and get back, "500 This security scheme is not implemented"

      Is there anything else i could try?

      thanks for any help,
      -- hugh.

      Comment


      • #4
        Do you have any control over the firewall? You could switch to active transfers, turn on the "Limit ports used for active transfers" option, and set up your firewall to open up and redirect those ports.

        Other than that, no. Your other options are (1) upgrade to non-lameftpd, (2) switch to SFTP (SSH2), or (3) connect unencrypted.
        Zoë P Scooter Software

        Comment

        Working...
        X