Announcement

Collapse
No announcement yet.

Time stamps preserved but displayed incorrectly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Time stamps preserved but displayed incorrectly

    I am in Vermont. I am working with a z/OS server that is in California. I upload a file that has a local time stamp of 10:32am. When I look at the uploaded file's time stamp by logging on to the z/OS system, it is correct: 7:32am. However, the BC directory listing shows the z/OS file has a timestamp of 3:32pm.

    I have preserve timestamp enabled.

    How can I get BC to show the correct timestamp for the z/OS files? Or, is 3:32pm correct in some way I don't understand? If so, can someone explain it to me?

    Thanks a lot.

    David Liebtag

  • #2
    Hi David,

    BC tries to auto detect time zone differences, but the auto detection might be failing in your case.

    It might help to manually specify the server's time zone. In BC3, select "Tools > FTP Profiles". Select the profile for your server. In the General tab, change the Time Zone from "Automatically Detect / Use Server Time" to Pacific Time.
    Chris K Scooter Software

    Comment


    • #3
      I tried setting the server time zone to Pacific time. It did not do any good. It looks as if BC always displays time stamps for file on servers in other time zones in UTC. Might that be?

      David

      Comment


      • #4
        I got it!

        I set the server to UTC time.

        David

        Comment


        • #5
          David,

          Glad that solved the problem for you.

          BC doesn't always display the time zone in UTC. Behavior varies quite a bit depending the FTP server software you're connecting to. The default settings in BC work with many FTP servers, but there is enough variance they can require tweaking to work with some servers.
          Chris K Scooter Software

          Comment

          Working...
          X