No announcement yet.

Can't get FTP sync to work

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't get FTP sync to work

    I have had recurring issues trying to use Beyond Compare FTP with various sites.

    Basically if I am managing a unix ftp server, then the file sizes are reported differently, so I can't use that as the criteria. I would be happy to use unix style ascii on my windows it an option to do that so that file sizes match..if so, how?

    In the past I've resorted to using timestamps and touching files wherever I go, and comparing just on timestamp, but this is a) not ideal b) not working right now.

    I've attached a screenshot. The two sides are the same, but Beyond Compare shows them as different.

    Is there some best practice of how to deal with this?

  • #2
    You can use binary transfers to keep the line ending style the same between the two systems. Use the Tools->FTP Profiles menu item, switch to the Transfer tab, and change the Transfer Type option to binary.
    Zoë P Scooter Software


    • #3
      And is this the recommended way of synchronising with a unix ftp server?

      Is there any other option?


      • #4
        The reason it's not working right now is because you're still comparing sizes. Turn off "Compare file size" in the "Comparison" tab of the Session Settings dialog and it will do a timestamp-only comparison.

        As for my suggestion, as long as the tools you're using understand the line endings, yes, that's the preferred method.
        Zoë P Scooter Software