No announcement yet.

SSH private key file - settings used for all profiles

  • Filter
  • Time
  • Show
Clear All
new posts

  • SSH private key file - settings used for all profiles


    I contacted you some time ago re problem that you can only specify one global SSH private key file - rather than one per FTP profile

    My workaround is to set one global file private.ppk and then I copy the particular key file I want to that name and then connect - none of the updates since have fixed it - maybe you've forgotten to fix this?



  • #2
    BC3's built in private keys support still only has a single global slot, but we did add support for Pageant, which is a program that can be used in conjunction with BC3 and supports multiple keys.

    How does this work for you?
    Aaron P Scooter Software


    • #3
      I cannot get it to work. I have a good private key that I use in a number of places and I know the server side is good. I set up an ssh profile, and gave it an open-SSH key, and it prompts for a password. Saved it as a .ppk (putty format) using puttygen and still prompts. I put the key in pageant. Putty goes in, but BC 3.3.4 refuses. Since ssh is notoriously difficult to debug, is there any way to tell what BC tried but didn't work? Log file, perhaps?

      Last edited by kovacsbv; 27-Nov-2012, 12:01 PM. Reason: Clarification


      • #4
        BC's password prompt is currently handled at a higher level than the public key support is, so it will still occur even if you have a valid public key configured. Just save the profile with a blank password and it should go through, barring any other issues. Once it actually does connect there will be logged items showing what authentication methods were tried.
        Zoë P Scooter Software


        • #5
          Thanks for the reply. It is currently configured with no password. I can see from the messages that it tried the key agent first, but failed.

          2012-11-27 12:22:15 Public key agent authorization failed.
          2012-11-27 12:22:15 Password authorization failed.
          2012-11-27 12:22:15 No more authentication methods available
          2012-11-27 12:22:15 Connection failed: Connection lost (error code is 10058)

          I currently have the key section blank so it will use Pageant, which it tries. This way, I can try BC against Putty with identical configurations. I had two keys loaded, but removed one to eliminate that as a variable. Putty goes straight in, BC does not.

          Could it be about the cipher, perhaps? Where do I tell BC which ciphers to use?


          • #6

            Thanks for the feedback. There might be an issue with your specific key and BC3. We've had a couple reports similar to this in the past, and regenerating the key usually gets it working. If you would like to email us your pair for us to troubleshoot this potential bug, it'd be greatly appreciated but we certainly understand if you cannot share this information.

            If you email us at [email protected] please include a link back to this forum thread.

            The next troubleshooting step would be to try a regenerated or new key pair to see if that will work with pAgeant.
            Aaron P Scooter Software


            • #7
              Ok, I'm working with support through e-mail.


              • #8
                Hi there,

                any news? Is there a chance to get to get SSH private key file for each profile on V4?




                • #9
                  This feature won't make it into the initial launch of BC4.0. In the BC4Beta we did try to rework the interface to help make it a bit clearer that the <default> controls the security settings, and individual profiles can then use those default settings. Pageant support is also still in, which can use Pageant to manage multiple keys for multiple profiles.
                  Aaron P Scooter Software


                  • #10
                    There was a miscommunication on our end. The next BC4 beta will have per-profile private keys.
                    Zoë P Scooter Software