No announcement yet.

Status of scripting?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Status of scripting?

    Is scripting now fully implemented in Cirrus?

    Any gotchas to watch out for in converting BC2 scripts to BC3?

    I probably dozed off, but the last mention I recall of scripting was in a Cirrus alpha when it was not implemented. I never saw a change log stating that it was implemented (and it's definitely not mentioned in the change logs since Cirrus went beta with build 400, except for one Linux fix last month), but the change log for the current version mentions some bug fixes in scripting, and I see that scripting is now included in the help file. So I presume that scripting has actually been included since a late alpha and I just missed the announcement?

    If it is fully supported, I look forward to saying goodby to my final remnant of BC2 (nightly scripted backup.)


  • #2
    I have no idea how we missed that in the changelog. Yes, scripting is implemented and has been since 441 was released in mid-November.

    Cirrus's scripting support is identical to BC2's with the following exceptions:
    1. The CRITERIA command doesn't support the TIMEZONE argument. On FTP sites this is handled by the FTP profile; for local/network drives it's currently unsupported. A warning will be written to the log this argument is present.

    2. The SNAPSHOT command doesn't currently support the SAVE-CRC, SAVE-VERSION, and EXPAND-ARCHIVES arguments and will always act as if NO-FILTERS was used. A warning will be written to the log if any arguments are used that don't match that case.

    3. OPTION STOP-ON-ERROR always works. I don't know how it got broke, but I wasn't able to find a version of BC2 where this actually worked as intended.

    4. OPTION CONFIRM now only affects file operation confirmations (overwrite newer, delete read-only, etc). BC2 inconsistently tried to apply this to other dialogs as well ("Enter zip password", "Printing Error", etc).

    5. /SILENT is now truly silent. Anything that tries to open an interactive dialog (excluding op confirmations) will now trigger a fatal scripting error.
    Zoë P Scooter Software


    • #3
      Thanks, Craig.

      FWIW the "Command Line and Scripting" help page still refers to BC2 rather than Cirrus.

      Also, that page should include a statement similar to this:

      "A session name may optionally begin with the name of its parent folder (with backslash as separator.) This is only necessary for disambiguation if several folders include sessions with the same name."

      I presume that this is also true of the load command in a script though I have not tested this.


      • #4
        Some scripting issues

        EDIT: Hopefully, # 1, 2, and 4 are due to the issue fixed in the 1/15 build. #3 was already present as a keyboard shortcut and was added as a context menu command in the same build. Thanks!


        More details sent by email. Posted here in case others see similar issues.

        1. memory leak. Log sent via email

        2. Access Violation at 00407D7E in cirrus.exe. Read of 80808080
        While syncing. Not reproducible.

        3. It would be useful to be able to copy text from the script log window (I had to retype the AV message, because I was not yet logging to file.

        4. Several times, after the script is finished (either because of being canceled or because of running to completion), the Cirrus window vanished, and the log showed "Script completed", but Win2K Task Manager showed Cirrus.exe still running and taking all the CPU time for its processor, for several more minutes until I killed the process. This does not happen every time, but did happen 3 times this evening out of perhaps 10 runs.
        Last edited by jdmarch; 15-Jan-2008, 07:57 PM.