No announcement yet.

Explorer Context Menu Install Fails

  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    BC menus aren't available on root folders (C:, D;, ...) here (Administrator on W7Pro64) but on any subfolder.

    Greetings Lutz


    • #17
      I have tried it on multiple folders and files, in windows explorer. I believe Aaron is correct in that the 64bit shell extension is not being installed for some reason.
      I just flowed the permissions down on the registry and tried to reinstall that didnt help either.


      • #18
        Here's a .reg file that should forcibly create all of the values you need for both the 64-bit and 32-bit shell extensions. It's set up for the default 64-bit Windows install, so you'll need to change paths if you installed outside "C:\Program Files (x86)\Beyond Compare 3".
        Zoë P Scooter Software


        • #19
          problem solved

          Really great!

          First time I used Registry Compare with HKLM/Software on left and Add CirrusShellEx.reg on right.

          Displaying same and right orphan keys showed up the following keys missing on my computer:
          Classes\*\shellex\ContextMenuHandlers\CirrusShellE x
          Classes\Folder\ShellEx\ContextMenuHandlers\CirrusS hellEx
          Microsoft\Windows\CurrentVersion\Shell Extensions\Approved

          Copied the three keys to left and instantly BC menus are visible at root folders, too.

          Greetings Lutz


          • #20
            Hi Craig,
            I have same problem with windows 7 and BC 2.3.1. (Worked for me on XP, and stopped after I received new laptop)
            The registry updates you have provided are referring to BC 3.
            Is it possible to publish similar reg updates for BC 2?


            • #21
              BC 2.3.1 is not compatible with Windows 7.

              BC 2.5.3 is compatible with Windows 7. To update, install version 2.5.3 over the top of 2.3.1. You can download version 2.5.3 here:

              A list detailing BC version compatibility with different versions of Windows is here:
              Chris K Scooter Software


              • #22
                Just an FYI:

                The context menu worked for me until I uninstalled from one location and installed again into a new location. After that it stopped working. (Win7Pro x64)

                I went through all the steps outlined on this thread and nothing worked until I imported the "Add CirrusShellEx.reg" registry file.

                Everything is back to normal now and the Explorer context menus work. However, the "Include Beyond Compare in Explorer context menu" still (always) shows as unchecked, while the sub-item settings do take effect (ie: Compare Using, Merge, etc., and None, Main menu, Submenu).

                Thanks for the help!


                • #23
                  I edited the registry file someone else posted on here so it's compatible with 32-bit (the other one is for 64-bit computers). I have it attached to this post.

                  Note to those who don't know if their computer is 32 or 64 bit, you can right-click on "My Computer" and it is listed at the "System Type" row

                  Additional note to those in the world wide web who, you have to create an account (for free) on these forums to download this file. After downloading it, you double click on the file and it will install (for Windows computers).

                  I am using a netbook with Windows 7 starter and it's 32-bit


                  • #24
                    Originally posted by Craig View Post
                    Here's a .reg file that should forcibly create all of the values you need for both the 64-bit and 32-bit shell extensions. It's set up for the default 64-bit Windows install, so you'll need to change paths if you installed outside "C:\Program Files (x86)\Beyond Compare 3".
                    I signed up so I could download this file, to see if my registry was missing anything. Sure enough, it was missing a few of the listed entries. I applied the reg, and I have working context menus. I'm on Win7 x64 and I am fully blaming my companies initial custom installer. Perhaps there could be a way to update the 'updater' to properly setup the context menus after a companies custom installer has broken things.

                    Thanks again,


                    • #25
                      Thanks, it does fix the problem!


                      • #26
                        I also signed up just to download the Add CirrusShellEx.reg for my windows 7 64bit computer. I used the installer from the website, and have admin rights, but explorer context menus would not work. After importing the reg file they now show up! thanks :-)


                        • #27
                          Still Missing Context Menu

                          I'm still having the issue on Windows 7, BC version 3.3.10. I have read all the way through the threads and followed the instructions - I have run the REG file Remove CirrusShellEx, uninstalled, rebooted, reinstalled, run the REG file Add CirrusShellEx, uninstalled, etc.

                          The correct options are set in BC itself, and all of the registry keys that are needed are there in the registry, but the context menu still isn't there in Windows Explorer. Any other ideas?


                          • #28

                            Sorry we missed a response when you originally posted in this thread. If reinstalling, rebooting, and using the REG file don't fix the problem, it's possible another shell extension is conflicting with Beyond Compare's shell extension.

                            If another shell extension is conflicting with BC, you can use ShellExView ( to toggle shell extension on/off to see if there is a conflict. You can skip toggling off shell extensions listed as made by Microsoft, some of them are part of Windows, and usually Microsoft shell extensions don't cause conflict issues.
                            Chris K Scooter Software


                            • #29
                              The above link is also specific for the 32bit reg patch (while the 64bit is on an earlier page). I would recommend emailing us with your OS information (version, and 32bit or 64bit) and we can email an up to date and appropriate version of the reg patch.
                              Aaron P Scooter Software


                              • #30
                                I'm facing with the same issue, everything tried in this post and more. But without any result.
                                Can you send me the req file for me?

                                Windows 8.1 Enterprise, 64-bit

                                Thanks for help!