Announcement

Collapse
No announcement yet.

Bug report: BC2 uninstaller removes BC3 context menu entries, hard to put back.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug report: BC2 uninstaller removes BC3 context menu entries, hard to put back.

    I have found a minor (but annoying) bug.

    When you un-install BC2, it removes the context menu entries both for BC2 but also BC3. This would be only a minor irritation if there was an easy way to put the BC3 menu entries back, but there is not.

    As far as I can tell, there is no 'repair' option on the BC3 installer, so the only way to get the context entries back is to fully un-install BC3, and then reinstall it. I was loath to do that because I was worried about loosing my settings, though in fact that did not happen.

    I think what is happening is that when someone runs the BC3 installer when they already have it installed, the installer assumes that it is updating BC3 to a new version, and leaves all preferences, including if there should be any context menu entries alone.

    In view of this bug in BC2, it might be a good idea to re-ask the user if they want those menu entries, so that they can easily fix the damage from this bug. The installer could read the current value and set the checkbox the same, so most upgraders would not have to change anything.

  • #2
    I'm sure Chris or Craig can answer this better, but I believe this is only a problem for some of the early Cirrus beta testers. The current releases of BC3 and BC2 are installed independantly of each other. Sorry for the trouble!
    Tim T Scooter Software

    Comment


    • #3
      I had the same problem, and think it was a late beta.

      I think I fixed it by going to 'Tools>Options' and unchecking Explorer integration and clicking Apply, then checking and clicking Apply.

      Comment


      • #4
        The officially released versions of BC3's shell extension are completely separate from BC2's shell extension.

        Enabling the shell extension in Tools > Options should add it back for BC3, please let us know if it doesn't.
        Chris K Scooter Software

        Comment


        • #5
          Still no BC3 context menu in WinXP x64

          I'm not getting context menu with BC3 and had BC2 installed.

          Here is my environment.

          I had been using BC2.2 I think.. on Windows XP... worked great.

          Got a new computer... Windows XP x64 on it, installed BC2.2 .. and of course there is only limited functionality... no context menus there, and since 2.2 was not supported on x64 I just lived with it and got by without context menus (real pain).

          Finally, found the company has an enterprise license for BC3.. Wooh! I think.

          Install BC3... it is installed parallel to BC2.2. Still no context menus.

          Used 'context explorer' tool to see whats loaded, and see there is a BC context menu item there, enabled but not doing anything. Tried disabling all the others (ISO recorder, Tortoise SVN, etc).. still no joy.

          Figure.. hm, maybe this is the BC2.2 version stomping on things... uninstalled BC2.2. Still no context menus.

          Unistalled BC3. Reinstalled BC3. Made sure that context menu support was set in the BC3 options...

          Still no context menus.

          Now, in 'context explorer' there is NO BC context menu item there at all!

          So now I'm thinking BC3 isn't even able to put the context menu stuff into the registry.

          Ideas?

          Is there a special x64 version of BC3 or is it one version supports all flavors?

          Comment


          • #6
            Hello,

            First, you must install a normal install of BC3, and not a Portable install. The normal install will install to Program Files, and will install the necessary shell extension components.

            There is not a special build for x64. If you go to the Tools menu -> Options, Startup, under the Explorer Integration section, do you have one of the options (such as Compare) enabled as Main Menu?
            Aaron P Scooter Software

            Comment


            • #7
              Hi,

              I am experiencing a strikingly similar situation. I was running BC2 then installed BC3 and uninstalled BC2. I have no shell menu options. I have run the utility to view installed extensions and nothing from BC shows. I have installed and uninstalled BC 3 a couple times, without any visible effects.

              I am running BC3 Standard on Windows 7 64 bit.

              Thank you.

              Comment


              • #8
                In case other users stumble across this thread, there is a possible solution here:
                http://www.scootersoftware.com/vbull...ead.php?t=5408
                Aaron P Scooter Software

                Comment

                Working...
                X