Announcement

Collapse
No announcement yet.

9357 label overspill

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Michael Bulgrien
    replied
    As Tim correctly described it, BC does not deliver fonts. It tells the OS what font to use (in this case, the Message Box font) and the OS "delivers" the font.

    Although we may never know for sure what happened on your system, the most common cause of such font issues is usually a missing or corrupt .ttf file on your system. When Windows cannot locate a font in the exact language/codepage that was originally defined, it substitutes a similar font. This can cause display issues as Windows uses the specifications from the original font (width of characters, etc.) while displaying an alternate font that may differ slightly from the original. Changing the font will usually correct the problem. Since the OS will only provide a list of the fonts that it knows to be valid on the system, reassigning a known font implements it correctly and eliminates the font substitution.

    Most likely the Message Box font defined on your system was not Tahoma. One possibility is that the Message Box font may have been altered sometime in the past when a Theme was applied to your system. Whatever the case, the defined font could not be found, so the Display settings defaulted to Tahoma while delivering font specifications for a font definition that it could not resolve.

    I am sure that the Scooter team will not be interested in dragging out an argument on this topic, but the fact is that your OS, for whatever reason, was performing a font substitution. Changing away from and back to Tahoma allowed the OS to correctly implement the Tahoma font on your system rather than to substitute a font for whatever was not working correctly before.

    Originally posted by Tim View Post
    I see your system's dialog font is different than chrroe's or mine. We'll try to improve this in a future release.
    In my professional opinion, Tim's original assessment was correct. He said that the Scooter Team would work to improve the handling of alternate Message Box fonts in a future release. Other than that, this was an OS font substitution issue, not an issue with BC3 displaying the incorrect font. A reason you may have noticed the issue in BC3 and not in other software is that BC3 allows buttons to be resized to minimum width eliminating the extra margin space on the button face that other products typically preserve.

    Leave a comment:


  • chrisjj
    replied
    > No, BC did nothing different after you made that change.

    It delivered a different font.

    Leave a comment:


  • Tim
    replied
    > It was apparently enough to convince your BC to provide the correct font when asked.

    No, BC did nothing different after you made that change. It asks the OS for the standard GUI font and uses what is given. I tried BC3 on 3 XP systems here and they all show Tahoma. I don't know why your system provided the wrong font.

    Leave a comment:


  • chrisjj
    replied
    > You might try setting the Message Box dialog font to something distinct like Comic Sans,
    > restart BC3 to verify that it follows this setting, and then put it back to Tahoma.

    Done... and the problem disappears.

    > This exercise might be enough to convince your OS to provide the correct font when asked.

    It was apparently enough to convince your BC to provide the correct font when asked.

    Leave a comment:


  • Tim
    replied
    You might try setting the Message Box dialog font to something distinct like Comic Sans, restart BC3 to verify that it follows this setting, and then put it back to Tahoma. This exercise might be enough to convince your OS to provide the correct font when asked.

    Leave a comment:


  • chrisjj
    replied
    > It looks like Chrisjj is using "Standard" font smoothing

    I'm using no font smoothing.

    > With the settings you've reported, the text does not get cut off
    > on my system regardless of the font smoothing settings in use.

    Puzzling...

    Leave a comment:


  • Michael Bulgrien
    replied
    Originally posted by chrisjj View Post
    > If you look closely, you'll see that they are different. Notice that your "V" is wider.

    I suggest that's due only to '[ ] Use the following method to smooth edges of screen fonts'.
    On second look, I agree. It looks like Chrisjj is using "Standard" font smoothing, and Chrroe is using "ClearType" font smoothing. That being said, I don't know why the text is being cut off on your system. With the settings you've reported, the text does not get cut off on my system regardless of the font smoothing settings in use.

    Leave a comment:


  • chrisjj
    replied
    > If you look closely, you'll see that they are different. Notice that your "V" is wider.

    I suggest that's due only to '[ ] Use the following method to smooth edges of screen fonts'.

    > It looks like chrroe's fone (and mine) is Tahoma and yours is MS San Serif.

    As I reported before, Display properties says it is the usual Tahoma 8pt.

    Or are you suggesting that BC is showing a font other than Display Properties says?

    Leave a comment:


  • chrisjj
    replied
    Thanks Michael, but as I reported before, Display properties says it is the usual Tahoma 8pt.

    > Tahoma works, for example, but Verdana gets cut off.

    Here Tahoma gets cut off.
    Last edited by chrisjj; 30-Nov-2008, 06:57 PM.

    Leave a comment:


  • Michael Bulgrien
    replied
    Chrisjj,

    Look at your Message Box font definition under Windows Display Settings \ Advanced Appearance settings:

    http://screencast.com/t/X3ynlJVHH

    Tahoma works, for example, but Verdana gets cut off.

    Leave a comment:


  • Tim
    replied
    > Looks same to me - and Display properties says it is the usual Tahoma 8pt.

    If you look closely, you'll see that they are different. Notice that your "V" is wider. It looks like chrroe's fone (and mine) is Tahoma and yours is MS San Serif.

    Leave a comment:


  • chrisjj
    replied
    Originally posted by chrroe View Post
    IMG-URL in the text
    Ah yes: http://www.scootersoftware.com/vbull...bbcode#imgcode

    Thanks.

    Leave a comment:


  • chrroe
    replied
    Originally posted by chrisjj View Post
    PS chrroe, how did you get that picture in your post, emebedded full-size?
    It is hosted externally at tinypic.com
    Simply upload it there and paste the resulting IMG-URL in the text, or use the "Insert Image" button.

    Unfortunatly it is the layout of the forum gets a bit distorted from bigger pics ...


    Bye
    Christoph

    Leave a comment:


  • chrisjj
    replied
    > I see your system's dialog font is different than chrroe's or mine.

    Looks same to me - and Display properties says it is the usual Tahoma 8pt.

    But I do have '[ ] Use the following method to smooth edges of screen fonts' and I now find if I change that I do get a spacing similar to chrroe's.

    > We'll try to improve this in a future release.

    Thanks.

    PS chrroe, how did you get that picture in your post, emebedded full-size?

    Leave a comment:


  • Tim
    replied
    I see your system's dialog font is different than chrroe's or mine. We'll try to improve this in a future release.

    Leave a comment:

Working...
X