Announcement

Collapse
No announcement yet.

No auto-saved sessions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No auto-saved sessions

    Hi,

    I don't see any auto-saved sessions whenever I start BC3. Even if I set any value other than 0 in Tools > Options > General > "max auto-saved sessions", the value gets reset to 0 every time I start it.

    I remember Erik had me remove some line from BCState.xml, when I experienced the crash in
    Beyond Compare 3.0.9.9222. The mails go like -

    1.

    >Hi,
    >
    >Thanks for the bug report. You have the "Sticky session selection" tweak on, right? This should be fixed in our next release (3.0.10).
    >
    >If you have any future crashes, please don't mess with the attachments. We need them to help track down the bug and only use them for this purpose.
    >
    >Thanks,
    >Erik Maly
    >Scooter Software

    2.

    >Hi,
    >
    >You'll also need to clear your mru session setting. To do so:
    >
    >1. In Windows Explorer, find your BCState.xml settings file (ex. C:\Documents and Settings\<username>\Application Data\Scooter Software\Beyond Compare 3) and open it in an editor (ex. Notepad).
    >2. Find the first instance "THomeState", delete the line below it that contains "SessionName" and save.
    >
    >Next time you start BC3, you shouldn't get this crash. You'll need to keep the tweak off until our next release.
    >
    >Let me know if you need any more help with this,
    >Erik Maly
    >Scooter Software

    Could you suggest how to recover that line if that's what is driving it.

    thanks!

  • #2
    Forgot to mention -
    1. The BC version I'm using now is 3.0.11 (build 9510).
    2. I have Tools > Options > General > "Include session management" checked.

    Comment


    • #3
      Have you tried moving your XML files to a backup folder and restarting BC3 as if it were a fresh installation? You can then use BC3 to merge back in the backed up XML configurations that are important to you. Just a thought.
      BC v4.0.7 build 19761
      ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

      Comment


      • #4
        Yeah. I could get going with that. I think one of the factors affecting this was Max# of saved session value. I put to insanely high value - something like 99999999. Is there some limit for this which I shouldn't exceed.

        Comment


        • #5
          Please reply to my previous mail. Do we have some limit for max. auto-saved sessions.

          Comment


          • #6
            NeOnD,

            I'm not sure what the exact limit is, but if you just enter 99999999999999999999 as the amount of auto saved sessions, it will prevent BC3 from auto saving any sessions. If you go back to the General section of Tools > Options, after entering such a large value it will reset itself to 0.

            If you set the auto saved sessions value to something smaller like 100 (the default), or 1000, it should display auto saved sessions correctly.

            I'll add this to our todo list to limit the input value for auto saved sessions.
            Chris K Scooter Software

            Comment

            Working...
            X