No announcement yet.

right click menu missing...

  • Filter
  • Time
  • Show
Clear All
new posts

  • right click menu missing...

    Hi Since installing the BC3 version (and uninstalling cirrus) I've lost the right click menu in explorer. I seem to remember an advanced settings in the cirrus installer for enabling this but I don't see it in the BC3 installer.

    This is the primary way I launch BC and would hate to lose this functionallity.


  • #2
    The update instructions should have asked you to uninstall Cirrus first, but it doesn't. The Cirrus uninstaller removes the shell extension registry entries; just enable it in the BC3 Options dialog again and it should reappear.
    Zoë P Scooter Software


    • #3
      Hi Dan,

      You can try turning on the shell extension from BC3's options.

      Select Tools|Options.
      In the Startup section, check "Include Beyond Compare in Explorer context menu".

      Please let me know if this doesn't make the shell extension show up on your computer.
      Chris K Scooter Software


      • #4
        I ran into the same problem.

        I installed BC3 build 453 on WinXP. On the first launch, I selected to import the Cirrus settings (which worked). Then I uninstalled Cirrus (build 449).

        The Compare item won't show up in the context menus.

        I've tried cycling the setting in Tools >> Options, and rebooting, with no effect.

        Are there registry items I should check?


        • #5
          I still have BC 2.5.2 installed. If I enable its setting for Explorer context menus, the Windows registry key HKEY_CLASSES_ROOT/*/shellex/BCShellEx is added.

          But BC3 doesn't place a key there.


          • #6
            BC3 still writes to HKEY_CLASSES_ROOT/*/shellex/CirrusShellEx. We were planning on removing the duplication but got some negative feedback about it.

            Frankly the easiest and quickest way to solve this will probably be to just uninstall and reinstall BC3. It won't remove your settings or anything, so it should come back unchanged.
            Zoë P Scooter Software


            • #7
              I just uninstalled and reinstalled BC3, rebooting afterwards each time. The context menu items are still absent, and so is the registry key.
              Last edited by Dave_L; 24-Apr-2008, 08:23 AM.


              • #8
                Any ideas on this? Is there a way I can manually restore the context menu?


                • #9
                  The attached zip has a .reg file that removes any trace of the beta shell extension from the registry. Try importing it, restarting BC3, and enabling it in the Options dialog.
                  Zoë P Scooter Software


                  • #10
                    Thanks, that fixed it.


                    • #11
                      Thanks Craig. I waited until this was finally resolved to uninstall Cirrus, since I almost always start BC with the Explorer Context menu option.

                      This morning, I uninstalled Cirrus, applied the registry fix and re-enabled the Context menu with Tools => Options.

                      I'm a happy camper again. Thanks.


                      • #12
                        More Right Click Menu Missing

                        I am not able to get the context menus for BC 3.0 with WIN 7 64 bit. I don't understand what Cirrus is, is it a program that should be deletable under Programs and Features?

                        I have installed and uninstalled multiple times requesting the install for all and all 3 options (context window, start menu, desktop). If I look at tools\option dialog box the "Include Beyond Compare in Explorer context menu" is checked and Compare is on Main Menu.

                        When I run ShellExView I do not see any entries for BC 3.0.

                        I imported the script given in an earlier post into my registry but still no dice.

                        When my computer was running XP this used to work for me but since I was upgraded to Win 7 the context menus do not work.

                        Do you have any advice for what I should try next?


                        • #13
                          Make sure you're using the installer from our website for the current version 3.3.8. Some of our customers repackage Beyond Compare into their own installer. Sometimes this breaks the shell extension if they don't do it right.

                          If that still doesn't fix the problem, other programs shell extensions can conflict with Beyond Compare's shell extension. You can use ShellExView to toggle shell extensions on/off to see if one is conflicting with BC. You can skip testing shell extensions made by Microsoft because many are part of Windows and don't cause problems.

                          You can download ShellExView here:
                          Chris K Scooter Software


                          • #14
                            In addition to Chris' comments, if you are still having trouble, please email us at [email protected] and include a link to this forum thread in the email.
                            Aaron P Scooter Software


                            • #15

                              i've the same problem. Where can i found the attached zip ?