No announcement yet.

B.C.3 prevents me from removing a usb key?

  • Filter
  • Time
  • Show
Clear All
new posts

  • B.C.3 prevents me from removing a usb key?

    I use B.C.3 to update an external usb key. Then, in B.C.3 I change folders and go to my internal drive, or even do a clear session. But, when I try to remove the usb key the system says that it is still in use. With ProcessExplorer I can see that B.C.3 has an open handle on the folder that I was working with. I have to close B.C.3, even if I am doing other jobs. Is it possible to modify B.C.3 so that, when I go to another folder, it does not keep an opened handle on the previous folder? It would be ok for me to do a clear session, if it is necessary.

    Thank You very much

    Rodolfo Giovanninetti

  • #2
    I just tested this on my XP machine with a USB drive and did not notice the problem.

    First, I ran a new blank Folder Compare comparison of my HDD <> USB drive. I tried to eject and it failed. I then used the Folder path dropdown to switch to another folder (a local HDD folder). Attempting to eject the USB then worked while BC3 was still open.

    Are you following similar steps? Do you have any other tasks in the background that could cause a conflict? Are you using the latest BC3 release (3.1.7)?
    If you try this on another computer, does it reproduce?
    Last edited by Aaron; 06-Nov-2009, 12:20 PM. Reason: different steps?
    Aaron P Scooter Software


    • #3
      I did again a test and I found some strange things. I compared C:\UTILITY\NIRSOFT with M:\NUMERO10 (M: is the external usb key). Then, on the right side, I move up twice, to M:\ first and then to a blank selection, whereas on the left side I stayed in C:\UTILITY\NIRSOFT. I tried to remove the usb key and the system said that it could not. I used ProcessExplorer and saw that B.C.3 (latest release) was keeping a handle on M:\ and on C:\UTILITY\. This seems strange to me because I was inside C:\UTILITY\NIRSOFT, not inside C:\UTILITY!
      I will send You a message, with screen shots and data file, with a link to this thread.
      So far, I have had no time to test on another system, as soon as I can I will let You know the results.

      Thank You again

      Rodolfo Giovanninetti


      • #4
        failing usb key

        When using BC a file was left open on the key blocking safe removal. I suspect an error while closing the file is causing the problem.

        Nirsoft openedfileview showed the file open after removing the usb key anyway.

        The usb key is a couple of years old.



        • #5
          We were able to track down Rodolfo's issue. It appears to be related to the Auto-complete function. Auto-complete, if used for typing a folder path, needs to point elsewhere before the usb key can be ejected.

          Are you having a similar issue with your file? Or do you think that it is a separate issue? Does Nirsoft openedfileview show BC3 as a locking application? You can use a program like Unlocker to try and narrow down if BC3 has a lock on the file. Does the issue reproduce? Does closing BC3 release the file?
          Aaron P Scooter Software