No announcement yet.

'0D0A'x - or line ending in Windows

  • Time
  • Show
Clear All
new posts

  • '0D0A'x - or line ending in Windows

    I think I had this working once before, but my PC got reloaded and the setting seems to have disappeared.

    My starting screnario is a comparison of PC and mainframe (cobol) files. The PC files have no trailing blanks, but they do have the '0D0A'x characters. The mainframe files, on the other hand are fixed length, 80 bytes with trailing spaces on each line. My first comparison resulted in the attachment 1. The blue guttering (?) indicates the fact that there are a load of (unimportant) characters on the mainframe. I got rid of the blue colouring by selecting Tools, Options, File Views, Compare Colors and then changing the unimportant colour to white. My next problem is the fact that when I click on the next difference section button, I get a message saying there are none (there clearly are). I'm guessing that the reason for this is that BC is "seeing" every '0D0A'x on every PC file line and thus consideres the whole file to be one massive difference.

    If this is correct, how do I change it.

    In reality, my question would probably be expressed better as, how do I get BC to totally ignore both trailing spaces as well as '0D0A'x

  • #2

    First, I would not recommend changing the Unimportant text color to 'white' to try and hide Unimportant differences. Instead, use the Ignore Unimportant Difference toggle in the View menu. This will ignore Unimportant (blue) differences, and hide them as Same text (black).

    To ignore trailing spaces and the Hex character, go to the Session menu -> Session Settings, Importance tab. Uncheck items to mark them as Unimportant, such as Trailing whitespace or a Grammar item defining your Hex value. Then toggle on Ignore Unimportant Differences to hide these blue differences.

    If you do not have a Grammar definition for the Hex value yet, then you can define one following this guide:

    Let us know if you have any questions.
    Aaron P Scooter Software


    • #3
      Thanks for the help Aaron

      That seemed to do the trick nicely.

      However .... I know for a fact that I've neved defined grammar items (?) before, and I could swear that I never saw this problem before. Ho-hum. It's fixed now and I've documented for myself the whole scenario, so I'm a happy camper.

      Thanks again.


      • #4
        Is it possible you enabled the "Compare line endings" option in the Text Compare's Session Settings -> Importance tab?
        If you enable Show Whitespace, do you see the Hex value as the line ending value (and marked in red or blue)?
        Aaron P Scooter Software


        • #5
          Sorry Aaron, I'm going to have to revisit this

          I've exported ALL my settings and will attach them. What I'm having problems getting my head around is shown in the following screen capture.

          The yellow area at the bottom shows that BC considers the trailing spaces to differ from the '0A0D'x of the PC file (that's understandable, sort of). However, the purple colouring shows that BC considers there to be no more differences (BC thinks it's one huge block of different lines ????)

          If I press the "Ignore unimportant differences", then the blue guttering disappears and I can "scroll" through the groups of differences.

          I could swear that, at one time, I saw all the lines like the first batch (IDENTIFICATION DIVISION forwards) as not being coloured blue and that I could scroll forward, difference to difference using the "Next difference section" icon.

          I attached an old screen capture (BC3 Screen10, though it looks like it's BC2) that I think, should show an old example of how I expect everything to work. Note that the premises should be the same - a PC file against a mainframe one. Here there is no blue guttering (in fact, it almost seems as if the trailing blanks have been stripped. Unfortunately, if you ask me what the settings were THEN, I can't tell you.
          Last edited by Aaron; 18-May-2010, 01:45 PM. Reason: Added another screen capture


          • #6

            I removed your settings file after downloading it (in case you did not want it publicly available). I believe the difference in your screenshots may be Whitespace. Enable the View menu -> Visible Whitespace option to see if the difference is there.

            If a difference is Unimportant, then it is colored blue, but is still treated as a Difference. Next Difference will still "hit" them as you click through. They will effect where difference sections are formed. Toggle on Ignore Unimportant Differences hides blue differences as black, allowing Next Difference to skip over them, etc.

            Whitespace difference is controlled in the Session Settings dialog -> Importance tab. Checked items are important, unchecked are unimportant.

            If you have any other questions, would you be able to include a pair of example files? If you need to, rather than posting them here you can email us at [email protected]

            If you email us, please include a link back to this forum post.
            Aaron P Scooter Software


            • #7

              I know I've seen the fact that one can download BC2 and test that as well - where was this ? It would be interesting to see if that handlse this problem differently (as possibly indicated in the screen capture)

              Found it
              Last edited by misi01; 19-May-2010, 11:22 AM.


              • #8
                Does this help at all ?

                Just happened across these 2 variations. The first 2 attachments show how I select a comparison and how the results shown are as I expect. The 2nd two show the situation as outlined above (in the last attachment, I pressed the "Ignore unimportant differences" icon before I saw the blue guttering)

                Is the first example a text compare, whereas the second is a folder compare and therein lies the difference ?

                Just downloaded BC2 and tested the 2nd variation. After some trial and error, I got the equivalent of the 3rd attachment layout to produce the 2nd attachment's results. Something's different, but what ???

                Update. The difference seems to be in the FTP transfer settings (BC2 has ASCII by default, but this results in Swedish characters being incorrect). In BC3, by default, I transfer using binary and use a file format using 1143 page code - this shows Swedish characters correctly, but with all the blue guttering. Change to ASCII and I see the same results as BC2. Finally, change to AUTO, and after changing the File format to 1143, I see the same results as the Binary option.
                Last edited by misi01; 19-May-2010, 06:10 AM.


                • #9

                  Different encoding can definitely make a difference in the comparison of your files. Perhaps try downloading from the FTP first, and compare the 2 files on your desktop? We can resume FTP troubleshooting once the actual file differences are determined.

                  Did you have a chance to send in that pair of example files? Which email did you send with? Did you include a link back to this forum post?

                  Also note that you are using a default color scheme that suppresses the background coloring. Normally those lines would have a blue background to indicate there is an unimportant character present (which would have blue character coloring).

                  Also, I notice from your screenshot that you do not have Visible Whitespace enabled. I strongly suggest enabling that so you can test to see if that shows the difference characters. Also, for troubleshooting purposes, do not enable Ignore Unimportant Differences. That will potentially hide the characters, making it harder to find where the differences are.

                  BC2 is available here, a left side link from our Download page:
                  Aaron P Scooter Software