Announcement

Collapse
No announcement yet.

Restart requires Block or Compressed transfer mode

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Restart requires Block or Compressed transfer mode

    2 questions.

    1) I'm getting the above message when trying to compare a PC folder with a mainframe file - the result is that NO files are being shown in the mainframe "folder" (I had a filter on, but even with a filter of *.* I still see nothing). Here is the log
    2010-04-26 08:31:48 Recv> 215 MVS is the operating system of this server. FTP Server is running on z/OS.
    2010-04-26 08:31:48 Sent> PWD
    2010-04-26 08:31:48 Recv> 257 "'userid.'" is working directory.
    2010-04-26 08:31:48 Sent> REST 1
    2010-04-26 08:31:48 Recv> 504 Restart requires Block or Compressed transfer mode.
    2010-04-26 08:31:48 Sent> REST 0
    2010-04-26 08:31:48 Recv> 504 Restart requires Block or Compressed transfer mode.
    2010-04-26 08:31:48 Sent> CWD 'userid.system.cobol'
    2010-04-26 08:31:48 Recv> 250 The working directory "userid.system.COBOL" is a partitioned data set
    2010-04-26 08:31:48 Sent> TYPE A
    2010-04-26 08:31:48 Recv> 200 Representation type is Ascii NonPrint
    2010-04-26 08:31:48 Sent> PASV
    2010-04-26 08:31:48 Recv> 227 Entering Passive Mode (192,168,237,253,234,116)
    2010-04-26 08:31:48 Sent> LIST
    2010-04-26 08:31:48 Recv> 125 List started OK
    2010-04-26 08:31:48 Recv> 250 List completed successfully.
    2010-04-26 08:31:48 Load comparison: H:\mash\mfe\projects\BOKA <-> ftp://[email protected]_address/'userid..system.cobol'
    2) On a different level, when I do an advanced search, I can specify that I want an exact match on the author (?), but not on the actual search string (I tried specifying "Restart requires Block or Compressed transfer mode" as the search criteria, but simply got LOADS of hits where each individual word was included). Is there any reason why an advanced search can't do an exact search as well on topic content ?

  • #2
    Okay - I think I can see a certain logic

    as to why I'm not "seeing" any items. I have a filter that excludes all files with a size of less than 1 byte. Having said that, the attached screen capture seems to show a logic "error". As can be seen, the size for the mainframe files is shown as empty (I get that BC doesn't know what their size is), but wouldn't it be more logical to include files whose size is unknown rather than exluding them ?

    I'm also wondering why, for example, BMAT3006 is included, since the filter specifically states that it should only include files starting with BOKA*.* (I tried changing to BOKA* as the filter, but that made no difference)

    Comment


    • #3
      Hello,

      The reason you are seeing BMAT is because Suppress Filters is enabled. This will show any normally hidden items as Teal in color. Disable Suppress Filters (glasses icon in the upper right, with a red slash through them) to hide Teal items.

      As for the No-Size items not appearing: that looks like a bug. I'll open a tracker entry for one of our developers to investigate that issue. Could you enable Debug messages by entering the Tweaks dialog (Ctrl+Shift+T), go to the Folder Views tab, and enable "Include debug messages in log". Then go to the Tools menu -> FTP Profiles, select your Profile, Connections tab, and turn the number of connections down to 1. Restart BC3 and connect to your trouble FTP.

      Could you then email us a copy of that log file. Please also include a link back to this forum post. Thanks.
      Aaron P Scooter Software

      Comment


      • #4
        A debug log isn't necessary. MVS just doesn't include size data; it's a limitation of the OS. Any other case where a size isn't available should exhibit the same issue.
        Zoë P Scooter Software

        Comment

        Working...
        X