Announcement

Collapse
No announcement yet.

Save is changing the record length

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Save is changing the record length

    I am doing a folder compare. I click on a file that exist in both folders and it comes up with the following. These are COBOL programs that were downloaded from the mainframe and now reside on my PC. The same problem exist if I update them directly on the mainframe

    <default> - 0037 (IBM EBCDIC) - US/Canada - MAC == on the left
    <default> - 0037 (IBM EBCDIC) - US/Canada - PC == on the right

    You know, it is a mystery how things get set. MAC ?? PC ?? I do not think that this is the problem because is also does not work if they are both PC. But where the heck does it come up with this and how would you change it?

    Anyway, If I merge some code (click the arrow and it is copied from one side to another) everything looks good. But then I save the changes. And the end of line character is now the first character of the next row. Everything is off by 1 character.

    I have a huge merge project coming up and need this fixed. I consulted several people at work and they all use version 2 - which works.

    Can I deconvert back to version 2?

  • #2
    Thanks for reporting the problem.

    Beyond Compare 3 detects the line ending style of files (PC, Mac, Unix, Mixed) when the files are loaded. To change the line ending style of files, select "Edit > Convert File > Line Endings > (ending style)", where ending style can be Windows, Unix, or Mac.

    If you'd still like to use version 2, you can download it from the following link: http://www.scootersoftware.com/download.php?zz=dl2_en

    Version 2 installs separately from version 3. If you still have your BC2 license, you can just paste it in to register version 2. If you need a version 2 license, send an email to [email protected] with the serial number for your version 3 license and we'll send you a version 2 license.

    To look up your 8 digit version 3 serial number, select "Help > About Beyond Compare" from the menu.
    Chris K Scooter Software

    Comment


    • #3
      This sounds more like an FTP transfer error than an encoding issue. Select Tools->FTP Profiles, then switch to the "Transfer" tab and change the "Transfer type" option from "Auto" to "ASCII". The mainframe should convert the files to something that BC understands when you download them, and converts it back when you upload them.
      Zoë P Scooter Software

      Comment


      • #4
        I downloaded the files onto my PC and did the compare there. Same result. So it is not FTP. File display fine in BC. I can delete lines and save. Files are fine. When I merge missing code from one side to the other everything looks fine. But when I save the changed file and then redisplay, the first merged line's EOLine character is now the first character of the next line and so it goes for every following line in the file.

        Comment


        • #5
          Just merged one line from one file to another both on the PC and the Mainframe using FTP. In both cases it was a problem. This problem is when I "copy left" or "copy right" an line that is on one side but not the other. If the line is on both sides but different, it works fine. So when i COPY the that only exists in one file to the other, i notice the end of line charcter is different. all the lines in the file have a box like end of line. The newly copied line has an asteric like character (i can look later in my hex editor). So it is the copy of a line that only exist on one side when the file has set length lines.

          Comment


          • #6
            Hi Brenda,

            Can you send us a pair of example files and your settings to [email protected]? To save your settings to a file, select "Help > Support" and click the Export button.

            If you can't send us example files, please let us know what the hex values of the line terminators are before the copy and the value of the asterix looking character after the copy. You can open the files in the BC3 Hex Compare to determine Hex Values.
            Chris K Scooter Software

            Comment


            • #7
              Sent the files and Export Settings on Friday.

              Comment


              • #8
                Thanks, I received the files and repeated the problem. I'm still trying to figure out what's causing it, I'll update you once I figure out more about the problem.
                Chris K Scooter Software

                Comment


                • #9
                  Hi Brenda,

                  I've verified this is a bug in BC3 that doesn't exist in BC2. Your files are 80 column fixed length files without line terminator characters. When you copy text between files, BC3 is inserting a line terminator character that is messing things up.

                  This bug is not in Beyond Compare 2. I've contacted you by email about providing you with a BC2 license until we get the bug fixed.
                  Chris K Scooter Software

                  Comment

                  Working...
                  X