Announcement

Collapse
No announcement yet.

ssh with asymmetric key login

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • blackpuma
    replied
    OK, simple enough. Thank you very much, Chris.

    Leave a comment:


  • Chris
    replied
    Try including the username in the path:

    sftp://[email protected]/

    You'll be prompted for a password the first time, which you can leave blank and check the box to save the password. After that you shouldn't be prompted.

    Leave a comment:


  • blackpuma
    replied
    Sorry I wasn't too clear. Yes, it does work.

    I was just wondering if there was a way to prevent BC from asking for the username and password every time.

    For example if the profile has:

    sftp://foo.bar.com/

    Leave a comment:


  • Zoë
    replied
    When BC asks for the password just leave the edit blank and select "Save Password". As long as you have your SSH key configured in BC or in ssh-agent (requires BC 3.2 beta), BC will try to log in using public key authentication before it tries with the blank password.

    Leave a comment:


  • blackpuma
    started a topic ssh with asymmetric key login

    ssh with asymmetric key login

    This is not a show stopper, but it's a little annoying.

    Situation:

    I have a web server that has password logins disabled. All logins are done using cryptographic keys on an alternate port. (Details at end under My Setup.)

    Question:

    I'm wondering if there is a way to get BeyondCompare to not ask for username and password when I use SFTP to connect to this site.

    Example:

    If I give BC the following:

    Code:
    sftp://foo.bar.com:12345
    BC will ask me for a username and password. I have to then enter in the username, and I can put anything whatsoever in the password field.

    If I do the following from the command line, no password is required.

    Code:
    $ sftp -oPort=12345 foo.bar.com
    Connecting to foo.bar.com...
    sftp> pwd
    Remote working directory: /home/me
    sftp>
    My Setup:

    BeyondCompare version: 3.1.11 (build 12238) for Linux
    Host OS: Centos 5.5 with all updates

    Remote sshd has the following in the ssh configuration file ( /etc/ssh/sshd_config )

    Port 12345
    PasswordAuthentication no
    RSAAuthentication yes
    PubkeyAuthentication yes
    Last edited by blackpuma; 24-Aug-2010, 11:37 AM.
Working...
X