No announcement yet.

Why can't I eliminate file differences?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Why can't I eliminate file differences?

    I develop web software on Mac and later post it on Unix server. For the purpose of keeping server up to date I use BC3 which is installed using Parallels WinXP virtual machine on my Mac. BC3's FTP is very convenient to compare and push updates to server. It works well but I encountered an annoying issue. After copying files to unix BC3 thinks that some (but not all) of them follow PC formatting standards for line ending. Files on my Mac are treated as Unix and therefore BC3 reports file differences. I attempted to eliminate these erroneous reports by either recopying files or using Edit > Convert File > Line Ending but did not achieve desired effect. Even though right after the operation BC3 thinks that files are the same pressing =? reports differences again.

    Am I missing something?

  • #2

    For FTP Transfers, you can go to the Tools menu -> FTP Profiles, select your profile, and in the Transfer tab, switch from Auto to Binary. Does this help with your transferred files and line endings? You can also enable Show Whitespace in BC3's Text Compare to see which line endings are currently used.
    Aaron P Scooter Software


    • #3
      Maybe using rules-based comparison, instead of binary comparison, would solve this.


      • #4
        Originally posted by LRaiz View Post
        pressing =? reports differences again
        Dave is right. When you click the =? button (compare contents) you should be presented with a Compare Contents dialog. Select the Rules-based compare option instead of the Binary compare option if you wish to ignore line ending differences.

        The following kb article makes references to size and datestamp issues when using FTP: Files are Different after Uploading to an FTP Site
        BC v4.0.7 build 19761