No announcement yet.

File Format settings for EBCDIC with encoding table 01143

  • Filter
  • Time
  • Show
Clear All
new posts

  • File Format settings for EBCDIC with encoding table 01143

    My problem is as follows.

    I have just installed BC and also added the encoding table 01143 (IBM EBCEDIC for Sweden/Finland) (This was done outside the product)

    When I try to open cobol-files from my TSO-session under IMS with EBCDIC it seems like the encoding doesn’t work (as shown by the attached screen capture)
    The results look almost correct using fileformat Cobol source with ANSI (apart from the special Swedish characters), but this doesn't (?) seem to make sense,
    since this would imply (?) that BC "sees" the source code as being on the PC (which it obviously isn't)
    The strangest thing is that it works for my colleges and we have tried everything we can think of.
    I attach my settings and look forward hearing from you

  • #2
    You're transferring the files from your FTP server using the "ASCII" transfer type, and the server is converting from EBCDIC to some ANSI variant before it sends it. In your FTP profile (Tools->FTP Profiles), open the "Transfer" tab and change the "Transfer Type" to "Binary". You'll probably need to add a maximum line length to your file format as well.

    Your "COBOL Ebcdic" format has too generic of a mask too; the format list is matched from top to bottom, so you should move it lower in the list so the PC-specific ones match first, or make the mask specific to ftp connections. I think "ftp://*" will work.
    Zoë P Scooter Software


    • #3
      Yes you were rigth.
      My FTP-profile was pointing do a default user and the default-user had the transfer-type set to ASCII.
      I changed it to AUTO and everything works greate.
      Thaks and Happy New Year


      • #4
        and ...

        ftp://* works as a mask. The original reason behind *.* was (my) lack of knowledge. I've created default settings that any of our users can import and didn't think of using your mask. At the same time, Joakim (joca06) was the first person to really test my documentation on importing and tailoring the settings individually (and it turned out they needed updating/correcting)


        • #5
          I'm going to have to back on that

          ftp://* doesn't seem to work. I include a screen capture showing the displayed results and my file format (if I use *.* then COBOL EBCDIC is selected from the file formats as required).


          • #6
            misi01, you're right, "ftp://*" doesn't work, for a couple of reasons.

            1) The file format matching is assuming any masks it gets use the local system's path delimiter ('\' in the case of Windows).
            2) '*' only matches a single directory level, not "anything".

            Fortunately, this works: "ftp://...\*".

            I'll make a bug tracker entry to improve this in some way. At the least, "ftp://.../*" should work, but doesn't.
            Zoë P Scooter Software


            • #7
              Thanks Craig - that worked beautifully