No announcement yet.

Network drive FAT32 not visible in 3.2

  • Time
  • Show
Clear All
new posts

  • Network drive FAT32 not visible in 3.2


    I have 2 licences, running the software on 2 Windows 7 64-bit notebooks.
    On one notebook I have downloaded the newest version of BC last December.
    But I ran into the issue that when I compare folders or files from my local hard disk with the ones on our network drive (Fat32) I don't see anything on the network location.

    That kept my from upgrading my BC3.1.11 to BC3.2.3 on my other notebook.
    Is there a setting or option that I need to change in BC 3.2.3?

    I've tried to check whether or not someone else has run into the same issue... My apologies if I missed that item.

    Best regards,

  • #2
    Thank you for reporting the problem.

    I'm not aware of any bugs in Beyond Compare 3.2.3 that should cause empty directory listings.

    Do the files show up in version 3.2.3 if you turn on "View > Suppress Filters"?

    What operating system is running on the network drive (Windows XP, Windows 7, non-Windows network attached storage appliance, etc)?
    Chris K Scooter Software


    • #3
      Sorry, your BC323 screenshot looks like you opened an empty directory.

      Could you please post screenshots of the same comparision using UNC-path for the network storage instead of the drive letter and without version window?

      Greetings Lutz


      • #4

        I've disabled the option 'Suppress filters', the result was that it seemed to visualize the subfolder (see BC323 - UNC Suppress.png).

        I've also repeated my actions from yesterday with a UNC path reference. (bc3111 - unc.png & bc323 - unc.png).
        The network drive is a Freecom Network Drive 500 GB.



        • #5
          Sorry, I did not notice changing sides in your first post.

          Looking at the log pane I see with 323 you load the parent folder of the 3111 base folder on server side, is this intended or do you have no access to the subfolder "HOVE- 3de leerjaar" using 323?

          But nevertheless the folder should be visible on the left in 323 without alignment.

          The Suppress Filters-screenshot shows a folder without name and size. Can you expand it?

          Greetings Lutz


          • #6
            It might help to update to the latest firmware for your Freecom Network Drive. We see a lot of mysterious errors with network storage devices, usually due to bad firmware that doesn't show up when connecting to Windows servers.
            Chris K Scooter Software


            • #7
              To Lutz: I'm not able to expand the subfolder.

              To Chris: I confirmed myself that the Freecom Network Drive was using the most recent firmware.
              The network drive drive is a USB/LAN drive, so its a non-Windows network attached storage appliance.

              Can I downgrade that version of BC from 3.2.3 to 3.1.11 in the meantime?


              • #8

                Please contact us by email at [email protected] and we can discuss providing the downgrade.

                We can also troubleshoot this further if you wish. One of the main options that was changed in BC3.2.3 from BC3.1.11 was the ability to follow symlinks. I would suggest going to your Folder Compare's Session menu -> Session Settings -> Handling tab, and try toggling the option "Follow symbolic links". Does this help?

                The other main option changed was to filter Protected Operating System files. To test this, please go to the Session Settings dialog -> Other Filters tab, and select DOS Attributes. Then try disabling the option to "Exclude protected operating system files (recommended)".

                Do either of these steps (or a combination) help connect or browse your NAS device?
                Aaron P Scooter Software


                • #9
                  I have a similar occurence on a (Linux-based) Fritz!Box. One of the folders stored in internal memory isn't accessible since few weeks. BC shows the folder icon but no name and size. Expanding this folder shows again the root folder contents (recursive).
                  Since behaviour is same using WE I would not suspect BC.

                  Greetings Lutz


                  • #10
                    Any progess on this?

                    I've recently updated BC, and now find this same problem on my NAS drive (opening a saved session that worked fine before the update). This is the same whether I refer to the drive by network name (\\nethd500) or map it to a logical drive (U. I am using Windows 7 Home Premium 64-bit, and driveinfo on the U: driver shows the following:
                    Volume Name: Users
                    File System: FAT32
                    Serial Number: 00000000
                    Max Name Length: 255
                    File System Flags:
                    IsSamba: False

                    (Support details attached)

                    Last edited by Aaron; 22-Mar-2011, 04:47 PM.


                    • #11

                      Thanks for the report. We should have a fix for you in the next release. Once it is available, please let us know if you are still having any trouble.

                      If you would like to rollback to an older version, please contact us by email and let us know at [email protected] and include a link to this forum post.
                      Aaron P Scooter Software


                      • #12
                        Any estimates on when the next release (with this fix) will be available, please?


                        • #13
                          We don't have an exact date, but we are currently testing a possible candidate. It should be soon.
                          Aaron P Scooter Software


                          • #14
                            Tony, we just released BC 3.3 beta this afternoon, you can get it here:

                            To update, install it over the top of the version you have.

                            Let us know if the new version doesn't fix your problem.
                            Chris K Scooter Software


                            • #15
                              Do you have a change log for the beta?

                              Edit: Never mind. I found it here.
                              Last edited by Michael Bulgrien; 09-Jun-2011, 08:52 PM.
                              BC v4.0.7 build 19761