No announcement yet.

Context menu lost

  • Filter
  • Time
  • Show
Clear All
new posts

  • Context menu lost

    I recently had to upgrade my boot drive, and in the process lost my BC3 settings.

    After I re-installed it, I had no context menu anymore, so I followed the instructions here and here.

    The context menu now works if I log in as admin, but as a limited user (which I normally work as) I still don't get anything.

    I'm running Windows 10 Pro, version 21H1, build 19043.1348, and a screenshot of some of the relevant info is available here.

    Anything else I could try? I can't really imagine working without the context menu anymore...

    P.S. I just upgraded to 4.4, and still the same behaviour — context menu shows up for admins, but not for restricted users.

    P.P.S. Using ShellExView I compared the loaded shell extensions between the two accounts, and it looks like the limited user has Client Side Caching UI enabled, whereas the admin doesn't:
    I tried disabling it using ShellExView, as well as the method described here, but so far that didn't help. Still looking...
    Last edited by Frescard; 18-Nov-2021, 08:55 PM.

  • #2
    I tried some more methods to disable cscui.dll; all without success, but I'm suspecting that that will turn out to be a wild-goose chase anyway.

    I've installed three other tools now, which use shell extensions (7zip, Input Director & TeraCopy), and they all work just fine on the restricted account, most of them not even requiring a reboot.

    So, there must be something unique/buggy about the BC extension that's causing these issues.


    • #3

      With ShellExView, if you disable all of the other extensions and then reboot, does this help? Sometimes there's a conflict between an existing extension and BC's. If this does help, slowly re-enable them to find the one that causes the issue. Being Admin might change the behavior just enough to dodge the conflict otherwise.

      It can also help to throw in a few more reboots. As the limited user, full clean uninstall BC3 and BC4, and run the Remove.reg patches to fully clean up the registry, and then reboot. Then step through the install of BC3 (or BC4) and at each step throw in one extra reboot.

      While may programs can avoid frequent reboots (BC3/4 included), once something isn't working they are important. We can't tell when Windows is locking our changes to the shell extension or caching something older, and it can really throw off troubleshooting efforts if you don't throw in a restart to confirm the change. I'll usually throw one in at the end of every step, if things are turning out particularly troublesome.
      Aaron P Scooter Software


      • #4
        I did about a dozen reboots yesterday — after every step, just like the one reference I linked to mentioned, but it didn't help.

        There is also no other extension that is currently active. The other programs I mentioned installed their own shell extension successfully, but they were all disabled when I tried BC.

        I switched to the free version of Code Compare now. It's doing everything I need, and its shell extension worked right out of the box. So, I guess that'll be my goodbye to BC (after many, many years...)


        • #5
          That's very odd. While it's not uncommon to have a shell extension conflict or for Windows to knock out our extension temporarily, I haven't seen a scenario where using shellexview to block extensions for troubleshooting, or fully removing the extension and adding it back using the reg patches, fail. You've certainly found the best resources and guides.

          If you'd like to troubleshoot further, just let us know. It might be best to go back and forth with email ([email protected] and include a link back to the forum thread for our reference).

          The key to using the reg patches is to fully uninstall BC4 and manually clean up the registry (just in case it is in any kind of bad state). You can then make sure the App's folder is completely gone and there are no Registry entries remaining (listed in the Remove.reg patch). Once it is in a clean slate (which can require the frequent reboots), it's all about attempting to re-install step by step (throwing a reboot in between, just in case): install program, checking the menu, then trying to use the Add.reg (with updated paths if needed) to manually create the registry entries. Something (usually OS update related) can 'kick' out BC4's extension, and adding it back this way almost always works.
          Aaron P Scooter Software