No announcement yet.

A keybinding bug..

  • Filter
  • Time
  • Show
Clear All
new posts

  • A keybinding bug..

    Linux version BC3.

    When binding a key with pop another dialog box's function, all keybinding is invalid.

    binding `Customize Command' with F10, if press F10 to invoke dialog , all keybinding is invalid.

    this problem is occur like `Sync Base Folder', it invoke it with some binding, all hotkey can not use. But if load it with menu mouse click, It work OK.

    BTW: if First press hotkey, and ALT+TAB switch to other window, and reswitch return, you will see the hotkey is invoked.
    Last edited by zw963; 27-Aug-2012, 10:29 AM.

  • #2
    And, I hope can offer belowing hotkey binding for:

    1. New Session dialog, can offer next-line, previous-line binding.
    2. Editor Can offer next-char, previous-char, next-word, previous-word binding.


    • #3

      Are you running the latest version of BC3 (3.3.5)?
      Which Linux OS and version are you using?

      On my test environment, I tried this:
      I opened a pair of folders in the Folder Compare session.
      I used a new shortcut (F10) to launch Sync Base Folders.
      Once open, shortcuts such as F5 or Ctrl F5, work.
      Does this same series of steps work for you?
      Aaron P Scooter Software


      • #4
        Thanks for the suggestion. Adding additional commands to be customized is on our Customer Wishlist. For now, however, several are hard-coded.

        Also, please be sure to be in the correct Session Type. The Customize Commands dialog only shows commands for the currently open view.
        Aaron P Scooter Software


        • #5
          Hi, this problem is exist how long long ago.

          My Linux Version: Slackware 13.37 64bit, and I use 32bit lib wrapper. It work file.
          BC3 I use the lastest 3.3.5, But before version is exist this problem.

          You step is same with me, But I test keybinding is C-n, C-p, it move previous-line
          and next-line, F5 or C-F5, I have tested just now, I run it some times, But only few
          times it work fine, Are you run just for once ?? Rare cases, It can work once.

          I like use hotkey to manipulate BC, But when invoke other `new keybinding setting'
          dialog(or window) use hotkey , It always not work for me. (except <RETURN> key)

          You can reproduce this bug like this:
          1. Open two file to compare.
          2. binding `Compare parent folder' with some binding. e.g. F10
          3. use F10 to invoke it, Pop a new window.
          4. press C-n or C-p , it not respond. keybinding is not work.
          5. ALT+TAB switch to other window, and then switch back, And here,
          you will see the C-n C-p track now...

          BTW: I USE XFCE 4.8 and Thunar 1.2 , And this related to This ?
          Last edited by zw963; 27-Aug-2012, 12:34 PM.


          • #6
            Addtion Suggest:

            When directory compare, allways exclude some file and folder, If exclude some not
            ought to exclude folder or files, It hard to fix this.

            Filter is so long, it too hard to find the exclude filter and delete it.
            I hope can have a `unexlude' or `include' keybinding, or just...

            `File Filter' menu, Why not offer edit function ?? only have a look is no sense.
            I don't want clear all filter or add full filter... can i pick some filter to remove convenient??

            Sorry, I edit my comment just now, `File Filter` can edit filter, It work fine, But when I post this thread yesterday, I use a hotkey to invoke it, e.g. C-M-f, when File Filter is active, all key input is invalid. So I think this only for look, Today, I invoke it with mouse, It can edit it now.

            oh... It all one problem... NEW WINDOW CAN NOT INVOKE WITH HOTKEY
            Last edited by zw963; 28-Aug-2012, 05:25 AM.


            • #7

              Why nobody return my message ??

              Are you reproduce the bug my mentioned ?


              • #8

                Following your steps I have not been able to reproduce this in my current test system. I do not have a slackware install, yet, however, so it may be specific to that OS.
                Aaron P Scooter Software


                • #9
                  I have resolve this problem. I replace with newest files version, It all worked now.

                  It should ought to the old version exist bug. But the new version has fix
                  this bug.

                  Thanks. BC3 is a great software. If not linux version BC3, perhaps I still use Windows now.
                  It is the only reason I use windows. But now. this reason is not existed.
                  Last edited by zw963; 30-Aug-2012, 09:40 AM.