No announcement yet.

How use BC with Nexus 10? (either MTP or PTP)

  • Time
  • Show
Clear All
new posts

  • How use BC with Nexus 10? (either MTP or PTP)

    The USB connection of the Nexus 10 offers only MTP mode or PTP mode. There is no option for mass storage mode (MSC), so the device does not appear as a drive letter.

    I can browse the file system in Windows 7, but I can't copy the path (i.e. Computer\Nexus 10\Internal storage\Movies) into Beyond Compare. It says "Folder Not Available".

    How can I make this work with BC? From my searches it seems that more and more Android devices are going with MTP, so this is an issue that will become increasingly important to solve.

  • #2
    Hi timg11,

    There are several FTP servers available on the Google Play marketplace that should allow you to access your files using BC. I haven't tested it yet, but there's also a Samba server available for use through a UNC path.

    I've already done some work to support MTP for a future release (post 3.x) and honestly I'd still suggest the above even once we have built in support for it. When I was testing against a Galaxy S III there were several issues that made it the worst choice. Specifically, setting last modified times wasn't supported, copying/moving files within the device required completely reading them and then writing them back, and renames failed if you tried to change the file extension.
    Zoë P Scooter Software


    • #3
      Thanks for the reply. Yes I have FTPServer by Andreas on the tablet. It works fine, but of course does not operate over the USB link, but uses Wi-Fi. Even with my 802.11n router, it seems to be fairly slow moving big files over Wi-Fi. USB has the potential for faster transfer, unless something in the tablet is the bottleneck.

      Are you aware of any way to create an IP network over USB between Windows and Android? That might make an FTP connection faster.

      Keep trying to make MTP work - it seems that we are stuck with it, and I prefer BC to the alternatives that I have tried. Another thread pointed to a program called PureSync that claims to perform synchronization to MTP devices, but I have not tried it yet.