No announcement yet.

Beyond Compare in WSL

  • Time
  • Show
Clear All
new posts

  • Beyond Compare in WSL

    I'm Using WSL on Windows 11.
    I installed bc in my machine and I get this when I try to check my git diff:

    Launch 'bc' [Y/n]?
    Some Shared Libraries were not found (0xf7f0f000) => not found => /home/lioriz/lib32/beyondcompare/ (0xf79e3000) => not found => /lib32/ (0xf79d8000) => /lib32/ (0xf79b5000) => /lib32/ (0xf79af000) => /lib32/ (0xf77c4000) => /home/lioriz/lib32/beyondcompare/ (0xf70b1000) => not found => not found => /lib32/ (0xf6ed0000) => /lib32/ (0xf6dcc000) => /lib32/ (0xf6dad000)
    /lib/ (0xf7f11000) => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found => not found
    This message is displayed because 'diff.tool' is not configured.
    See 'git difftool --tool-help' or 'git help config' for more details.
    'git difftool' will now attempt to use one of the following tools:
    opendiff kdiff3 tkdiff xxdiff meld kompare gvimdiff diffuse diffmerge ecmerge p4merge araxis bc codecompare smerge emerge vimdiff

    I tried:
    • sudo apt-get install zlib1g
    • sudo apt-get install libxtst6
    and I tried:
    • sudo dpkg --add-architecture i368
    • sudo apt-get update
    • sudo apt-get install zlib1g:i386
    • sudo apt-get install libxtst6:i386
    But nothing helped and it stayed the same.
    Last edited by LiorIz; 17-Feb-2022, 03:21 AM.

  • #2

    BC4 on Linux uses QT4. I'm guessing that is the missing library. It's also baked into the install if it is missing from the system, but this was testing on Linux, not WSL. We did get it working in the past, but WSL is changing and updating fairly frequently, so I wouldn't be surprised if there was something that now has to be resolved manually. I'll have to dig into it.
    Aaron P Scooter Software


    • #3
      Thank you Aaron,
      Would it help if I use BC3 instead?
      Please Let me know if you need more data from my side.


      • #4
        BC3 is QT3, which is even older. I'll need to set up a test system (in a way that doesn't break my virtual machine test environment). Did you get a chance to try installing a version of QT4?

        Also, I suggest testing outside of version control initially. Just try launching "bcompare".
        Aaron P Scooter Software


        • #5
          Oh, sorry, perhaps I misread: if you have BC3, then you'd definitely need to install QT3 manually (it isn't packaged in like BC4's QT4). I'd strongly suggest trying the BC4 trial to see if it works, as I suspect getting BC3 running in this environment to be difficult.
          Aaron P Scooter Software


          • #6
            You didn't say what Linux distribution you're running in WSL.

            Ubuntu 16.04 is the newest version that is compatible with BC 3.3.13 for Linux. The oldest version of Ubuntu for WSL I see listed in the Windows Store is 18.04, for that version or newer you'll need to use BC4.

            Linux Distribution Compatibility:
            Chris K Scooter Software


            • #7
              Following our install guide to wget the .deb, sudo apt update and sudo apt upgrade and then sudo apt install the deb, I can get bcompare running on Windows 11 via wsl's default Ubuntu distro.
              Aaron P Scooter Software


              • #8
                Thank you Aaron,
                But it did not worked for me

                Click image for larger version  Name:	bcompare wget failed.jpg Views:	0 Size:	248.8 KB ID:	87472


                • #9
                  Originally posted by LiorIz
                  Thank you Aaron,
                  But it did not worked for me
                  It worked!!
                  I removed bcompare- sudo apt remove bcompare and deleted it from my bin folder, reinstall it- sudo apt install ./bcompare- and it worked.
                  Thank you Aaron!!
                  Last edited by LiorIz; 21-Feb-2022, 03:37 AM.


                  • #10
                    Good to hear. And for troubleshooting, I'd recommend not calling from Git (as a first step) and instead just launch "bcompare" to see if the program can launch at all. This helps separate to a simpler call, and if that's working, you could then build back up to being a difftool
                    Aaron P Scooter Software