Announcement

Collapse
No announcement yet.

10221 Data COmpare missing one line on left side

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • chrisjj
    replied
    > If the right file has column names, then they will be used for the both the left and right side.

    OK, thanks. I suggest this be mentioned in the Help.

    > For the Data Format change issue, we'll have it fixed in the next release.

    Thanks.

    > In the current version, if you click to focus on the other side, then change the Data Format, it should work correctly.

    It does - thanks.

    Leave a comment:


  • Chris
    replied
    Chris,

    The column names are filled in from either the left or right file. If the right file has column names, then they will be used for the both the left and right side.

    For the Data Format change issue, we'll have it fixed in the next release. In the current version, if you click to focus on the other side, then change the Data Format, it should work correctly.

    Leave a comment:


  • chrisjj
    replied
    > The reason you are still not seeing what you want is that you only
    > changed the format for the left side

    Well yes, but I didn't see the expected effect on the left side.

    I.e. I changed the left "First line contains" to "Cell data" and yet still the left side interpreted the first line as "Column names". This surely is not WAD.

    > change it for the right side as well.

    Thanks - that worked.

    > You can change both at the same time by using the "Data Format"
    > toolbar button picker instead of the file info pickers.

    Thanks. Note: this doesn't work after I only change the left side - the format menu already shows my "Cell data" format active and clicking it again has no effect. I suggest if the UI cannot handle showing mixed format, it should show no format. Else at least a click on the one shown selection should be accepted.

    Leave a comment:


  • Erik
    replied
    The reason you are still not seeing what you want is that you only changed the format for the left side, but you need to change it for the right side as well. You can change both at the same time by using the "Data Format" toolbar button picker instead of the file info pickers.

    Leave a comment:


  • chrisjj
    replied
    OK, thanks...

    ...but the problem persists: http://img253.imageshack.us/img253/3967/tempx.gif

    EDIT: The following workaround has worked once out of five attempts: Session | Reload Files.
    Last edited by chrisjj; 30-Apr-2009, 11:25 AM.

    Leave a comment:


  • Michael Bulgrien
    replied
    Make sure your "File Info" header is enabled (under the View menu). It includes a format dropdown that can be used on-the-fly to view your files using a different file format.

    Leave a comment:


  • chrisjj
    replied
    > You can then pick it manually when needed

    How, please?

    Leave a comment:


  • Aaron
    replied
    Hello Chris,

    You can clone your File Format, change the setting, and then place it lower in the list, below the original so it is not used automatically.

    You can then pick it manually when needed, or set the Session to use it in the Session Settings automatically for that session.

    Leave a comment:


  • chrisjj
    replied
    > Because column 9 in your files doesn't use a consistent format

    It consistently uses the format string!

    > you'll need to edit the Data Compare file format
    > and change the "First line contains" setting to "Cell data".

    That's unacceptable becasue it will break many other other cases which are working OK.

    How many I apply the "First line contains" == "Cell data" to just the problem session?

    Leave a comment:


  • Chris
    replied
    Chris,

    Thank you for sending the settings files. I discussed this with Erik, and we determined it is due to a combination of your Windows regional settings and the data being compared.

    The Data Compare looks at the first two lines of text and determines the column types (text, date, etc). If the column types are different, then BC treats the first line as a header. If the column types are the same, then it treats them both as data.

    In the files you sent, the first line in column 9 is "1937-07-26". With your Windows regional settings (short date format yyyy-mm-dd), this is detected as a date. The second line is "1937-1943", which is detected as text. Because the data types are different, BC treats the first line as a header.

    On a default US English system (our office test systems), the short date format is M/d/yyyy, so column 9 for both lines is detected as text. This makes BC treat the first line as data.

    Because column 9 in your files doesn't use a consistent format, you'll need to edit the Data Compare file format and change the "First line contains" setting to "Cell data".

    Leave a comment:


  • chrisjj
    replied
    > Please send your settings.

    Done.

    Leave a comment:


  • chrisjj
    replied
    >> "King of Rhythm 1937-1944" is a detected column name, surely??
    > Nope, the first and second line have the same format so it
    > shouldn't be detecting column names.

    I would like to 100% clear here. Are you are saying this is NOT a detected column name?

    Leave a comment:


  • Erik
    replied
    Nope, the first and second line have the same format so it shouldn't be detecting column names. Is it possible you assigned names (ex. "Fill Names Using Left File")? Please send your settings.

    Leave a comment:


  • chrisjj
    replied
    > I do not see detected column names like in your screenshot.

    "King of Rhythm 1937-1944" is a detected column name, surely??

    Leave a comment:


  • Erik
    replied
    I do not see detected column names like in your screenshot. Please send your settings files (Help -> Support) and I'll try to reproduce it using them.

    Thanks,

    Leave a comment:

Working...
X