Announcement

Collapse
No announcement yet.

453 Hex Viewer barring writes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 453 Hex Viewer barring writes

    HV works fine on e.g. 80Kb files but on e.g. 7Mb files it has a problem - it seems to bar other programs from writing to the file.

    Is a fix planned?

  • #2
    I can confirm this issue.

    When very large files are in a BC3 Hex compare, Ultra-Edit returns the following error dialog:

    Cannot Save File
    File/Device may be ReadOnly, or open for write by another application!
    Use 'Save As' to save as a different name.
    BC v4.0.7 build 19761
    ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

    Comment


    • #3
      By default, Hex Compare has a 2MB threshhold for loading files into memory and freeing the lock on the file. To change it, go to the Home view, select Edit session defaults > Hex Compare and change the "Keep an in-memory copy of files smaller than" setting.
      Tim T Scooter Software

      Comment


      • #4
        Belatedly, thanks.

        And FTR, on BC3 12204 this is renamed: Keep an in-memory copy of files smaller than

        PLEASE would you add this to the Help? After wasting time searching the Help in vain for locks etc., I had to search the UI, and oin finding it eventually there, I see the Help for that dialog has no mention of this option. BC would be so much better if you completed the Help!

        Comment


        • #5
          The option is described in the Help file under the Session Settings section as a size limit that allows editing in other programs (and above it would "bar writing.")

          You can go straight to a Help file by loading a Hex Compare (which would have been loaded at the time of the comparison), then go to the Session Settings and click the '?' button to navigate straight to the Help article detailing the settings.
          Aaron P Scooter Software

          Comment


          • #6
            > The option is described in the Help file under the Session Settings section ...

            Ah, I guess that must be a Help content addition since this version, though I see none mentioned in the changelog.

            Thanks.

            Comment

            Working...
            X