Announcement

Collapse
No announcement yet.

14128 Data Compare with extra row

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 14128 Data Compare with extra row

    How do I get this kind of alignment:

    http://img526.imageshack.us/img526/6...41clipboar.png

    in Data Compare? Currently I get this

    http://img804.imageshack.us/img804/6...41clipboar.png

    and setting ID to unimportant or inserting a blank on the right does not solve it.

    Thanks.

  • #2
    In addition to setting ID as unimportant, set one or more of your other columns as "key" columns. If you don't want the records to sort by the key column(s) then go to Session Settings and check "Unsorted alignment".
    BC v4.0.7 build 19761
    ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

    Comment


    • #3
      Originally posted by Michael Bulgrien View Post
      In addition to setting ID as unimportant, ... then go to Session Settings and check "Unsorted alignment".
      Thanks, but though that undocumented checkbox does indeed seem to have some side effect (additionally to disabling sort), the result is still a fail:

      http://img249.imageshack.us/img249/6...41clipboar.png

      Comment


      • #4
        Actually, you don't need to make ID unimportant...it can be a normal column. The problem is that you still didn't make one or more of the other columns a "key" column. Try column 8, for example. Right-click on the column header and make it a key column instead of a normal column.
        Last edited by Michael Bulgrien; 17-Nov-2011, 01:20 AM.
        BC v4.0.7 build 19761
        ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

        Comment


        • #5
          Thanks - sorry not to say, but I avoided a key column because BC will only only align rows with matching keys. That happens to be acceptable with that data but with data differing in the key column it causes fail e.g. http://img706.imageshack.us/img706/5...ildatacomp.png whereas again Text Compare succeeds http://img9.imageshack.us/img9/4384/...xttextcomp.png .

          EDIT: Solution found: unset key columns, checkmark Unsorted alignment, insert blank line, and do Recompare FIles: http://img843.imageshack.us/img843/5...ildatacomp.png . I think my previous blank line attempt's fail must have been due only to not doing Recompare Files, expecting it to be automatic.

          Thanks again Michael.
          Last edited by chrisjj; 17-Nov-2011, 08:41 AM.

          Comment


          • #6
            The blank line method works so long as you have the "Unsorted alignment" option checked.
            BC v4.0.7 build 19761
            ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

            Comment


            • #7
              Indeed - added to recipe above. Thanks.

              I do wish it was not necessary to do such guesswork on undocumented/undefined behaviour in order to get such a simple non-heuristic compare to work. Let alone to rely on this subtlety continuing to work on future BC versions. Devs, would you please give this matter some attention? FAOD, this is not a Help Suggestion.

              Comment


              • #8
                Thanks for the suggestion and screenshots. Improving the Data Compare is something we are looking into. If you would like, please post or email in a pair of sample files we can add to our test cases. If you email us, please include a link back to this forum post for our reference.
                Aaron P Scooter Software

                Comment


                • #9
                  > If you would like, please post or email in a pair of sample files we can add to our test cases

                  OK. How do I save just the one session's Settings to send?

                  Comment


                  • #10
                    You can use the Export wizard to select specific sessions or settings, or you can just send in your entire BCSupport.zip from the Help menu -> Support; Export.
                    Aaron P Scooter Software

                    Comment

                    Working...
                    X