No announcement yet.

Unable to load base Error

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to load base Error

    I have set up 2 BC3 scripts. One script copies some files from a VMWare virtual machine on my local computer to a development server. The other script copies files from my development server to my production server.

    The scripts write messages to a log file on my desktop:
    log normal "C:\Documents and Settings\pmolaro\Desktop\BC3Synclog_PROD.txt"

    Then they go through a series of 8 file synches that look like this:
    # ========= EXAMPLE SYNCH =========================
    # Exclude certain file types
    filter "*.swf;*.xml;*.jpg;"

    # Load the base folders
    load "V:\Inetpub\MySite\wwwroot\assets\Flash\banner " "Y:MySite\wwwroot\assets\Flash\banner"

    #expand to affect subfolders and files
    expand all

    #confirm yes
    option confirm:yes-to-all

    # Copy different files left to right, delete orphans on right
    sync mirror:left->right
    #================================================= =

    The "Local to Dev" script runs without any issues. However, the "Dev to Production" script always returns this error:
    3/31/2010 2:04:01 AM Fatal Scripting Error: Unable to load base folder
    3/31/2010 2:04:05 AM Script completed in 4.05 seconds

    To make the "Dev to Production" script I have duplicated the "Local to Dev" script and simply changed the drive mappings, so instead of pushing from V: to Y:, I am now pushing from Y: to X:

    I have rights to all the mapped drives and even make sure I am logged into each before I run the scripts.

    Any ideas on why the script works in one environment but not in another??

  • #2
    Could you clarify the steps you take to be" logged into each before I run the scripts"? This is most commonly caused by the script user not having access, or the driver letters are not ready.

    If you run the script manually from the command line, does the current Windows user have access to X: (and Y? Also, sometimes the Drive letter is not "ready" at the time the script is called. If you call the script and have issues, can you access the drive letter with My Computer? After successful access, does calling the script again work?

    One common fix is to call the remote share directly (\\computername\Folder) instead of the drive letter.
    Aaron P Scooter Software


    • #3
      I have the drives mapped on my local machine to those drive letters mentioned.

      When I say logged in I mean that for each I go to the drive mapping directly (opening My Computer) and I double click the ones I need. The production mapping typically ISN'T logged in so it prompts me for my account info, I supply it and can then browser the drive. The other drives (local and dev) are typically logged in already as I use them often.

      I am running the script via the command line, yes. I made the txt file script then set up a .bat file that I can double click to run the script.

      I will try the drive name instead of letter but I am not sure that will help.


      • #4
        Is that a typo? Shouldn't there be a backslash between Y: and MySite?



        • #5
          @Christoph yes, sorry that was a typo in my post. The actual script has "Y:\" for each block (I just double checked to be sure).


          • #6

            Did you get a chance to test accessing the \\sharename\folder? If you try loading these driver letters or \\sharename\folder locations with the graphical interface, do you also encounter the error?
            Aaron P Scooter Software


            • #7
              yes, using the share name instead of the drive letter seems to make it better. In almost all of your samples you have the drive letter, so maybe for others a note should be added (unless there is one I missed).

              Also, if i needed to authenticate to one of my drives, how do I do that in the BC3 script? I tried to append one of my paths with: MyPassword /user:xxx\username but that didn't work.


              • #8

                You can't specify the username and password in script for a network share (although, you can for FTP).

                You can access the drive and save the password outside BC3 for your windows user, or you can use the net use command from the command line in a bat file before running the BC Script from the bat file.

                You can use "net use /?" at the command line for a list of arguments.
                Aaron P Scooter Software


                • #9
                  Reboot fixes this

                  Originally posted by pmolaro View Post
                  The "Local to Dev" script runs without any issues. However, the "Dev to Production" script always returns this error:
                  3/31/2010 2:04:01 AM Fatal Scripting Error: Unable to load base folder
                  3/31/2010 2:04:05 AM Script completed in 4.05 seconds
                  I was scratching my head over this same error. Just for grins I rebooted and it worked. Go figure.


                  • #10
                    I'm getting this error again on a new script that was copied from an old one.

                    Regardless of the outcome I would really like to see more information when the error occurs. That is, "The system cannot find the drive specified" is pretty vague. Which drive? would be useful.

                    Maybe an enhancement request?

                    Thanks... Bob


                    • #11
                      Once again, rebooting to the rescue. Any suggestions?

                      Windows 7
                      64 bit
                      Network drive
                      Connected with NetworkDriveManager


                      • #12
                        This error is usually due to the network drive not being available at the time the script is attempted. Failing to load a base folder is a fatal error, and BC3 scripting immediately exists.

                        How often does your script run and how often do you run into this error? Are you bound to a drive letter or accessing the network path directly with \\computername\folder? If using the network path, are you using the \\computername\folder or \\ipaddress\folder? Sometimes, the IP Address is a more stable method of connection, as long as it is not changing. Would this be an option for you?
                        Aaron P Scooter Software


                        • #13
                          I thought I replied but it has not shown up. Is there a delay? Moderator?


                          • #14
                            Our forum only requires moderation of the first post for new accounts. Your posts shouldn't require moderator approval, so the last post we can see in the forum is the "rebooting to the rescue" post marked 10:43 AM yesterday.
                            Chris K Scooter Software


                            • #15
                              This only happens when I first create the script. Once it is working it is rock solid.

                              There are three drives involved:
                              The source drive, local.
                              The target drive, network S:
                              The script drive, network N:

                              Since the script runs but can't complete I'm assuming that the problem is with the target S: drive. This is generally a new drive, recently defined but connected with NDM.

                              The session invoked by the script will run just fine outside of the script. The curious thing is: why does rebooting fix it?

                              This is not a big deal for me just annoying. It happens just often enough that I can't remember from last time what I did.

                              Great product, extremely useful in many ways. THANKS.. Bob