Announcement

Collapse
No announcement yet.

can't set some fonts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • can't set some fonts

    i'm having a difficulty setting some fonts for file comparison - when i set them the default font is used instead. the issue affects only some of the fonts i have installed, and seems to only affect file comparison - the same font displays fine in folder comparison.

    win-xp sp2, bc3 v3.0.446.

    forgot to mention : same fonts work fine for file comparison in bc2 installed alongside.
    Last edited by grunt; 12-Mar-2008, 02:22 PM. Reason: forgot to mention...

  • #2
    What fonts do you have trouble with?
    Tim T Scooter Software

    Comment


    • #3
      i haven't tested this too thoroughly, but it would seem that the problem manifests itself with bitmap fonts (those that come in *.fon files).

      Comment


      • #4
        MS San Serif and MS Serif (bitmap) fonts work for me. But Modern and Script don't. It seems to be fonts with limited character sets that have trouble (where Script choices don't include Western).

        We'll look into it.
        Tim T Scooter Software

        Comment


        • #5
          please do - i use a set of good fixed-width fonts for all my coding-related activites (including diffing, of course ), and quite a few of those are bitmap fonts.

          Comment


          • #6
            For your preferred fonts, in the Font dialog, what are the choices in the "script" dropdown?
            Tim T Scooter Software

            Comment


            • #7
              Try unchecking the "Use Font Linking" option in the Tweaks dialog (Ctrl+Shift+T?). Font linking allows us to display characters that aren't supported by the current font, but the fonts your having trouble with may not work with it.
              Zoë P Scooter Software

              Comment


              • #8
                I was right about the cause; it only affects OEM/DOS bitmap fonts while font linking is active. The next release will disable font linking for those fonts.
                Zoë P Scooter Software

                Comment


                • #9
                  Originally posted by Tim View Post
                  For your preferred fonts, in the Font dialog, what are the choices in the "script" dropdown?
                  Sorry for the delay...

                  "Western", "Other", "OEM/DOS", some language specific ones too...

                  Comment


                  • #10
                    again, sorry for the delay...
                    Originally posted by Craig View Post
                    Try unchecking the "Use Font Linking" option in the Tweaks dialog (Ctrl+Shift+T?).
                    yup, un-checking "enable font linking in editors" worked like a charm (in the sense that selected font appears).
                    Originally posted by Craig View Post
                    Font linking allows us to display characters that aren't supported by the current font, but the fonts your having trouble with may not work with it.
                    whose issue is this? qt? windoze? cirrus?

                    Comment


                    • #11
                      Originally posted by grunt View Post
                      whose issue is this? qt? windoze? cirrus?
                      Well it's fixed in Cirrus, but the problem is a combination of IE and the specific font. Font linking is an IE technology that works by asking the font what character ranges it supports; for any characters outside those ranges it falls back to another font that does support the characters. The bitmap fonts that have trouble report that they don't support any ranges, so it uses the secondary font for everything. I'd guess that the file format the fonts are in just doesn't support that feature, and the IE team didn't think it was important enough to support such an edge case.

                      We don't use Qt for the Windows version, just the Linux one.
                      Zoë P Scooter Software

                      Comment


                      • #12
                        thanks for both clarifications.

                        Comment

                        Working...
                        X