Announcement

Collapse
No announcement yet.

Can't seem to ignore columns

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't seem to ignore columns

    I have defined a new File Format for a text file I am trying to compare. Columns 92 thru 97 (inclusive) contain a date field I wish to ignore.

    I've labeld my Grammar Element as Alcohol Date, and checked the Trailing Whitespace and Everything Else boxes as well as Orphan lines are always important (after all, if a line is missing from this report, I want to know it!).

    In the Edit Grammar option, I have the following rule:

    Alcohol Date=Column from 92 to 98.

    Upon closing, the comparison reloads and behold! All the dates in columns 92 thru 98 still show in Red! I have tried clicking Ignore Unimportant Differences, to no avail.

    I have attached my BC Settings (well, at least I think I have). Any idea what I'm doing wrong?

  • #2
    Once you define "Alcohol Date" in "Edit Grammar", make sure you uncheck "Alcohol Date" in the Importance tab of Session > Session Settings. Editing the grammar just defines what "Alcohol Date" is, checking or unchecking the box in the Importance tab defines if it is important or unimportant.

    Also, to make sure the text is matching the grammar item, try clicking to put the cursor in the text you want to ignore. It should list the grammar element name for the current cursor position in the status bar.
    Chris K Scooter Software

    Comment


    • #3
      So the logic is negative - that is define the rule, then uncheck it to identify it as Unimportant.

      And it worked great - thanks Chris.

      Comment


      • #4
        Elements can be either an Important or an Unimportant Difference; we default to Important, which is represented by checking the checkbox. Defining an element also lets you configure syntax coloring.
        Aaron P Scooter Software

        Comment

        Working...
        X