Announcement

Collapse
No announcement yet.

problems comparing data in 3 (excluding certain words)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problems comparing data in 3 (excluding certain words)

    Hi,

    in version 2, I created a regular expression


    .*Script Version.*

    I have added this to the grammar section in 3 (hopefully correct), but it still marks up files being different, when I wish to ignore any lines containing 'Script Version' (this is the only change in many files, so obviously need to avoid having to manually check these files)

    I have searched the various help files, and to be honest I am no further forward

    Any suggestions as to how I can achieve this.

    Thanks.

  • #2
    In Session Parameters, in the Importance tab, You should uncheck the Grammar element corresponding to your RE.
    Michel Dessaintes
    Modérateur du Forum Francophone & Traducteur Officiel de BC2/BC3/BC4 en Français

    Comment


    • #3
      thanks - but can't see this

      There is nothing like this under the sessions dropdown (as far as I can see)

      I am comparing folders & files within those folders, and need to avoid comparing files that have simply a new version number, but th rest of the text stays the same.

      thanks.

      Comment


      • #4
        I am not a specialist (only the French translator), but I achieved what you are asking in this way:

        (1) Menu Tools/File Formats: I created a new file format "ScriptVersionFileFormat" (unchecked it):
        Mask=*.txt
        Grammar item=Basic/.*Script Version.*/Regular expression

        (2) On the Text Compare session default, uncheck the grammar item in the Importance tab.

        (3) In the Folder compare session, check the ScriptVersionFileFormat in the Misc tab of the set the session settings.

        This will work if the new file only has orphan lines containing ".*Script Version.*".
        Last edited by mdes; 21-Mar-2009, 05:15 PM.
        Michel Dessaintes
        Modérateur du Forum Francophone & Traducteur Officiel de BC2/BC3/BC4 en Français

        Comment


        • #5
          Originally posted by canvey View Post
          There is nothing like this under the sessions dropdown (as far as I can see)
          The "sessions dropdown" is not where you set your session settings.

          When in your file compare, click on the Session Settings button on the toolbar (the referee-man with striped shirt). From here, click on the Importance tab. The grammar element you added should be listed here. Make sure that there is no check in the checkbox so that the grammar is considered to be unimportant. Choose "Also update session defaults" and click OK to save your changes.
          BC v4.0.7 build 19761
          ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

          Comment


          • #6
            Thanks - still no joy...

            clearly I am doing something wrong

            Clicked on the 'ref', and I have a pop-up box with....

            specs, comparison, handling, name filters, other filters, misc

            Thanks.

            Comment


            • #7
              sorry (maybe this explains the issues) - this post should be under folder compare.

              My apologies.

              Comment


              • #8
                Your grammar definitions must be defined and configured in the context of a Text Compare. Folders do not have grammar elements.

                Open a text compare with the file types you've created the grammar for and check the Importance settings as explained above.

                Enable the "Ignore unimportant differences" button () in the toolbar.

                Open a folder compare, select the files to compare, right-click on the selection, click "Compare Contents" from the context menu, then choose "Rules-based comparison". This will use the grammar rules you defined for your file-type in the text compare.

                Note: You can also configure BC3 to perform a rules-based compare by default
                BC v4.0.7 build 19761
                ¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯

                Comment


                • #9
                  Hello,

                  To configure specific text to be unimportant for the comparison, first configure a Text Compare to correctly identify this (as Blue/Unimportant Text), to make sure your definition is correct.

                  Once it is, you can then pass those settings back (lower left dropdown on the Text Compare Session Settings), or set as the defaults (lower left dropdown, or on the Home Screen: Edit session defaults -> Importance tab, uncheck grammar).

                  Then in the Folder Compare, you can run Content Comparisons, one of which is the Rules-based Content Comparison. This will use the default rules, which we would have set to treat your grammar as Blue Unimportant, which can then be ignored with the Ignore Unimportant Differences toggle in the Toolbar (of the Folder Compare; also exists in the Text Compare).

                  1. Set up once in a Text Compare
                  2. Set up as the default for all Text Compares
                  3. Set Folder Compare to use rules-based (Text Compare) settings for the comparison, instead of Timestamp/Size.
                  Aaron P Scooter Software

                  Comment

                  Working...
                  X