Announcement

Collapse
No announcement yet.

switch to ignore embedded whitespace doesn't seem to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • switch to ignore embedded whitespace doesn't seem to work

    I am comparing files that have lines with numbers separated by spaces. I want to get a comparison that only shows the the differing numbers in red, but I get other numbers in red as well and the only difference is that there are varying numbers of spaces between them. For example, here are 2 lines from the different files. Only the first number is different, but it shows 3 numbers being different. I have marked them with an asterisk. If you remove the asterisks

    1* 0* 0 6 0 1 1 256 0 16 0 0 0 0 2 1* 1

    7 0 0 6 0 1 1 256 0 16 0 0 0 0 2 1 1

    If you paste these lines separately into 2 files and do the comparison it shows those numbers in red. I have all the whitespace variations in the Importance tab -> Default text panel unchecked.

    How can I modify settings to do what I want?
    Thanks for your time. This is very important to me. I have files with lots and lots of lines like these and it would be MUCH easier to compare if this could be done.

  • #2
    Hello Ken,

    I created two temporary files and pasted in the lines above (without the '*') and they seem to compare as you expect.

    Are you using the latest version of BC3 (3.2.4)? You can update for free from the Help menu -> Check for Updates or from our website:
    http://www.scootersoftware.com/download.php

    If you are still having trouble, could you post a full screen screenshot? Or even better would be to email us a pair of sample files and your Support package (from the Help menu -> Support; Export).

    Our email is [email protected] , and please include a link back to this forum post as reference.
    Aaron P Scooter Software

    Comment


    • #3
      Forum software removes multiple spaces to one space. Using the example by copy/paste needs to add some additional spaces.

      I put one space between the last two numbers and got following Aligned Detail result (#=gap, *=red):
      Code:
      1* 0 0 6 0 1 1 256 0 16 0 0 0 0 2 #  1 1*
      7* 0 0 6 0 1 1 256 0 16 0 0 0 0 2 1* 1 #
      There's no difference changing any whitespace options.
      Looks like a problem of inline alignment.

      Greetings Lutz

      Comment


      • #4
        I did download the latest version. However, as Lutz pointed out in his post after yours, the forum removes extra spaces, so yes, they will compare exactly. But if you take the two lines and add extra spaces to each line (in different places), then you do get red numbers if you do the comparison.

        Any suggestions on how to remedy this?

        Thanks.

        Comment


        • #5
          Ken's issue was resolved via email. It turned out that he had a grammar element defined that matched embedded whitespace and was marked as important.
          Erik Scooter Software

          Comment

          Working...
          X