Announcement

Collapse
No announcement yet.

Session Settings

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aaron
    replied
    Hello,

    To create a clone format with all the grammar items of another format:

    1) Open the Tools menu -> File Formats
    2) Select RTF (*.rtf) format.
    3) Click Save As.
    4) Type in a new, uniquely identifying name. like "Txt Files with RTF grammar items"
    5) Select the "Txt Files with RTF grammar items" in the left side list of file formats. Should be selected by default when created, but just double check.
    6) In the General tab, change the Mask from "*.rtf" to "*.txt"
    7) In the Conversion tab, change the conversion dropdown from "Rich Text Formatting" to "None"
    8) In the Grammar tab, double check that your grammars are still there and defined. They should be.
    9) Click Save to save the changes.

    You now have a new file format with the previous grammar entries, but usable on plain text files. Alternatively, you can just create a new Text Format from scratch and redefine all the grammar entries manually.

    This format will not automatically be used in a session. Instead, when you open a session and pass in a pair of files, it will pick the file format based on the first match in the File Formats dialog. The topmost format that matches the file Mask will be used. This cannot be overridden from a Text Compare.

    From a Folder Compare, you can alter the session to only use certain file formats for any child comparisons.

    Do the above directions help get you a File Format that has the grammar entries? I suggest first testing in New sessions instead of previously saved sessions. Once that is working, move into previously saved sessions.

    Leave a comment:


  • purchase
    replied
    Hello Aaron,

    Thank you for answering. If it wasn't there, I couldn't find it...! Another item to review for a partial GUI overhaul...!

    Thank you for your explanations, but up to now, I don't really understand them.

    1. I've got a "session" named "rtf <--> rtf"; I've saved it; all the "importance" settings are there.

    2. I reopen that setting for other rtf files; all settings are there; this remains so even if I import in one of the two panes the clipboard content, and even if the clipboard content is in reality in .txt format, not .rtf.

    3. I put two new files into the panes, .txt files; they will open, but my settings (1.) are gone.

    4. So I try with your explanations, or with what I understand there. I reload the above "session" (1.); I do "save as"; I name it "txt <...> txt"; all the settings (1.) are there.

    Now I try your "Then edit this clone's file mask to open *.txt, and disable the conversion in the Conversion tab.":

    5. I now "edit this clone's file mask to open *.txt": You mean I now put two text files into the two panes? I do this, and the settings (1.) are all gone.

    6. I now "disable the conversion in the Conversion tab": There's a format tab, where "default" is selected (all sorts of formats could be selected, but no ".txt"); there's a second tab for character encodings; on the tab, there's "ANSI", but in the selection roll-down, this corresponds to the very first entry, "Don't override", and selecting this again, again gives "Ansi" as the button inscription. You say, "disable the conversion in the Conversion tab" - HOW to do that? Which one is the "Conversion tab", and what entry means "disable the conversion"?

    In the help file, there is the item "Text format conversion settings" with "The Conversion tab defines how files should be loaded and saved.", but it's not stated where to find the conversion tab.

    And there's (in the same "Text format conversion settings": "The following variables will be replaced with the indicated information:
    %s source file
    %t target file
    %n original file
    %x original extension, including '.'"

    Where can I see those variables, let alone edit them?

    Perhaps the above-mentioned "file mask" was my error, and I should have put these "*.txt" into the fields, without paths and filenames?

    7. So the two tabs are "Default" and "Ansi", and of course, all my settings (1.) are gone...

    8. In the buttons bar, there's a button called "Format", which allows for selecting the wanted format, EXACTLY in the same way the first one of the two tabs (6.) does. I don't understand why this functionality is doubled, but anyway, my settings are gone, and a ".txt" format isn't in that list listed either.

    Please have a look from where on I divert from your explanations.
    Last edited by purchase; 28-Nov-2011, 04:42 PM.

    Leave a comment:


  • Aaron
    replied
    Hello,

    Grammars are saved as part of the file format, so if you are export/importing, you will need to include the File Formats, too.

    You also would need to re-define the grammar elements for the new file format as well, but you do not need to do this entirely manually. The main difference between the txt File format and the File Format for rtf would be the external conversion. Make a new clone of your defined RTF file format (with all of your grammar items already defined). Then edit this clone's file mask to open *.txt, and disable the conversion in the Conversion tab. This should leave you with a plain text format with all the original grammar items still defined.

    Your session setting defaults use the grammar names to determine importance defaults. Since the grammar items will have the same names, the importance should still be treated with the same defaults in the new file format.

    How does this work for you?

    Leave a comment:


  • purchase
    started a topic Session Settings

    Session Settings

    Hello,

    Thank you very much for answering my sorting questions, must have a look into all this, up to now do a lot of sorting within editors, and must see BC's scripting possibilities. (As I'm touting BC everywhere, please allow me for touting EmEditor here, not expensive, and VERY good, and many elaborated commands available by simply chosing them from the menu, whilst for elaborated commands in my other editors, TSE = The Semware Editor, and KEdit, you need to do heavy diving into the help files, etc.)

    Please allow me one very dumb question, I simply don't find the answer. There's export and import of session settings to and from another pc, but I've got a lot of text compare settings for a session, I save the session, I can open it again for same-format files, all very well.

    But all this for .rtf format only. If I load .txt files in order to compare, all my settings are gone, and I simply cannot configure out how to re-load all these "rtf" settings for my txt files (where I need the same "grammar").

    I even got an unwanted second instance of BC in my unsuccesful tries, whereas all I want to have is the possibility to compare .txt files instead of .rtf files, within the same tab or in another tab, not important, of (always) the same instance of BC, without my rtf grammar settings vanishing.

    Of course, I could re-do all those grammar details, one by one, for a new "session", but that cannot be it.

    I'm absolutely sure I'm overlooking things, but I've read a lot of menu entries, a lot of help file items, a lot of forum posts, and I simply do not get it. So, as in the case of my newbie questions 1 month ago, yes, I'm dumb sometimes, but again, other people also are, sometimes, so these are GUI problems of BC that should be exterminated, since, again, many people do not post forum questions (and buy softwares), but simply leave and go to a program they "spontaneously understand", and in BC's case, that would be, for most of them, leaving BC for an inferior program, and that'd be a pittance indeed.

    EDIT :

    And also, I'd like to save "sessions" or whatever, without specific files to be loaded, just a name and grammar settings to use for the comparing, but no automatic loading of files I'm done with and that perhaps don't even exist anymore. All this is mixed up in my mind, perhaps - but perhaps only - because BC is too much inclined to support the comparation of the same files, again and again, then, not allowing enough flexibility for comparing NEW files, with OLD settings? At the very least, the commands spontaneously offered by BC for settings storage are this way that you turn around and around but do not get what you want... in my case that is.
    Last edited by purchase; 28-Nov-2011, 07:47 AM.
Working...
X